aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
Diffstat (limited to 'math')
-rw-r--r--math/aspcud/Makefile3
-rw-r--r--math/kalgebra/Makefile8
-rw-r--r--math/minizinc-ide/Makefile3
-rw-r--r--math/py-pyasp/Makefile3
4 files changed, 17 insertions, 0 deletions
diff --git a/math/aspcud/Makefile b/math/aspcud/Makefile
index 3efc37592c73..241b78576467 100644
--- a/math/aspcud/Makefile
+++ b/math/aspcud/Makefile
@@ -12,6 +12,9 @@ COMMENT= Advanced solver for package dependencies
LICENSE= GPLv3
+DEPRECATED= Uses EOL Python 2.7 via math/gringo
+EXPIRATION_DATE=2021-06-23
+
BUILD_DEPENDS= re2c:devel/re2c
LIB_DEPENDS= libboost_thread.so:devel/boost-libs
RUN_DEPENDS= gringo:math/gringo \
diff --git a/math/kalgebra/Makefile b/math/kalgebra/Makefile
index faa51e4ccbc7..a2b95baea982 100644
--- a/math/kalgebra/Makefile
+++ b/math/kalgebra/Makefile
@@ -30,4 +30,12 @@ WEBENGINE_DESC= Add dependency on qt5-webengine
WEBENGINE_USE= QT=webengine
WEBENGINE_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_Qt5WebEngineWidgets
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MWEBENGINE}
+DEPRECATED= Uses EOL Python 2.7 via www/qt5-webengine
+EXPIRATION_DATE=2021-06-23
+
+.endif
+
.include <bsd.port.mk>
diff --git a/math/minizinc-ide/Makefile b/math/minizinc-ide/Makefile
index ccb809077f63..bccca268b819 100644
--- a/math/minizinc-ide/Makefile
+++ b/math/minizinc-ide/Makefile
@@ -10,6 +10,9 @@ COMMENT= IDE for MiniZinc, a constraint modeling language
LICENSE= MPL20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+DEPRECATED= Uses EOL Python 2.7 via www/qt5-webengine
+EXPIRATION_DATE=2021-06-23
+
RUN_DEPENDS= minizinc:math/minizinc
USES= gl qmake qt:5
diff --git a/math/py-pyasp/Makefile b/math/py-pyasp/Makefile
index e285692ad05e..c2df03d34ab3 100644
--- a/math/py-pyasp/Makefile
+++ b/math/py-pyasp/Makefile
@@ -11,6 +11,9 @@ COMMENT= Convenience wrapper for the ASP tools gringo and clasp
LICENSE= GPLv3
+DEPRECATED= Uses EOL Python 2.7 via math/gringo
+EXPIRATION_DATE=2021-06-23
+
RUN_DEPENDS= clasp:math/clasp \
gringo:math/gringo