aboutsummaryrefslogtreecommitdiff
path: root/misc/boxquote.el/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/boxquote.el/Makefile')
-rw-r--r--misc/boxquote.el/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/misc/boxquote.el/Makefile b/misc/boxquote.el/Makefile
new file mode 100644
index 000000000000..b385713bc239
--- /dev/null
+++ b/misc/boxquote.el/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: boxquote.el
+# Date created: 14 Jul 2006
+# Whom: Andrey Slusar <anrays@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= boxquote.el
+PORTVERSION= 1.18
+CATEGORIES= misc elisp
+MASTER_SITES= http://www.davep.org/emacs/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= # empty
+EXTRACT_ONLY= # empty
+
+MAINTAINER= anray@FreeBSD.org
+COMMENT= Quote text with a semi-box in Emacs/XEmacs
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+EMACSLISPDIR= ${PREFIX}/share/emacs/site-lisp
+XEMACSLISPDIR= ${PREFIX}/lib/xemacs/site-lisp
+
+PLIST_FILES= share/emacs/site-lisp/${PORTNAME} lib/xemacs/site-lisp/${PORTNAME}
+PLIST_DIRS= lib/xemacs/site-lisp lib/xemacs
+
+do-install:
+ ${MKDIR} ${EMACSLISPDIR}
+ ${MKDIR} ${XEMACSLISPDIR}
+ ${INSTALL_DATA} ${_DISTDIR}/${DISTNAME} ${EMACSLISPDIR}/${PORTNAME}
+ ${LN} -sf ${EMACSLISPDIR}/${PORTNAME} ${XEMACSLISPDIR}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>