aboutsummaryrefslogtreecommitdiff
path: root/misc/gretl/files/patch-plugin::Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'misc/gretl/files/patch-plugin::Makefile.in')
-rw-r--r--misc/gretl/files/patch-plugin::Makefile.in51
1 files changed, 51 insertions, 0 deletions
diff --git a/misc/gretl/files/patch-plugin::Makefile.in b/misc/gretl/files/patch-plugin::Makefile.in
new file mode 100644
index 000000000000..1c2311d1564b
--- /dev/null
+++ b/misc/gretl/files/patch-plugin::Makefile.in
@@ -0,0 +1,51 @@
+--- plugin/Makefile.in.orig Thu Mar 28 07:05:24 2002
++++ plugin/Makefile.in Thu May 2 01:46:10 2002
+@@ -2,6 +2,7 @@
+
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
++libdir = @libdir@
+ CC = @CC@
+ CFLAGS = @CFLAGS@
+ MAKE = @MAKE@
+@@ -21,7 +22,7 @@
+ endif
+
+ # Installation directory
+-share = $(prefix)/share/gretl
++gretldir = $(libdir)/gretl
+
+ LIBTOOL = $(topsrc)/libtool
+ COMPILE = $(LIBTOOL) --mode=compile $(CC) -c -fPIC -DPIC $(CFLAGS)
+@@ -29,8 +30,8 @@
+
+ GRETLINC = -I$(topsrc)/lib/src
+ GRETLLIB = ../lib/libgretl.la
+-GTKINC = `gtk-config --cflags`
+-GTKLIB = `gtk-config --libs`
++GTKINC = `$(GTK_CONFIG) --cflags`
++GTKLIB = `$(GTK_CONFIG) --libs`
+
+ PLUGINS = stats_tables.so panel_data.so progress_bar.so \
+ gnumeric_import.so excel_import.so
+@@ -85,15 +86,15 @@
+ .PHONY:
+
+ install: $(PLUGINS) installdirs
+- $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) \
+- $(PLUGINS) $(share)/plugins
++ $(LIBTOOL) --mode=install $(INSTALL_DATA) \
++ $(PLUGINS) $(gretldir)/plugins
+
+ install-strip: $(PLUGINS) installdirs
+- $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) -s \
+- $(PLUGINS) $(share)/plugins
++ $(LIBTOOL) --mode=install $(INSTALL_DATA) -s \
++ $(PLUGINS) $(gretldir)/plugins
+
+ installdirs:
+- $(topsrc)/tools/mkinstalldirs $(share)/plugins
++ $(topsrc)/tools/mkinstalldirs $(gretldir)/plugins
+
+ clean:
+ rm -f *.o *.lo $(PLUGINS) core