aboutsummaryrefslogtreecommitdiff
path: root/misc/xplr/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/xplr/Makefile')
-rw-r--r--misc/xplr/Makefile30
1 files changed, 29 insertions, 1 deletions
diff --git a/misc/xplr/Makefile b/misc/xplr/Makefile
index 253316256b97..bd9f8e0d5af1 100644
--- a/misc/xplr/Makefile
+++ b/misc/xplr/Makefile
@@ -1,6 +1,6 @@
PORTNAME= xplr
DISTVERSIONPREFIX= v
-DISTVERSION= 0.4.4
+DISTVERSION= 0.5.4
CATEGORIES= misc
MAINTAINER= lcook@FreeBSD.org
@@ -18,6 +18,7 @@ CARGO_CRATES= anyhow-1.0.40 \
arrayvec-0.5.2 \
atty-0.2.14 \
autocfg-1.0.1 \
+ base-x-0.2.8 \
base64-0.13.0 \
bitflags-1.2.1 \
blake2b_simd-0.5.11 \
@@ -33,6 +34,8 @@ CARGO_CRATES= anyhow-1.0.40 \
cfg-if-1.0.0 \
chrono-0.4.19 \
clap-2.33.3 \
+ colored-2.0.0 \
+ const_fn-0.4.6 \
constant_time_eq-0.1.5 \
criterion-0.3.4 \
criterion-plot-0.4.3 \
@@ -44,13 +47,21 @@ CARGO_CRATES= anyhow-1.0.40 \
crossterm_winapi-0.6.2 \
csv-1.1.6 \
csv-core-0.1.10 \
+ darling-0.10.2 \
+ darling_core-0.10.2 \
+ darling_macro-0.10.2 \
+ derive-new-0.5.9 \
+ derive_builder-0.9.0 \
+ derive_builder_core-0.9.0 \
digest-0.8.1 \
dirs-3.0.1 \
dirs-sys-0.3.5 \
+ discard-1.0.4 \
dtoa-0.4.8 \
either-1.6.1 \
fake-simd-0.1.2 \
filetime-0.2.14 \
+ fnv-1.0.7 \
fsevent-0.4.0 \
fsevent-sys-2.0.1 \
fuchsia-zircon-0.3.3 \
@@ -59,7 +70,11 @@ CARGO_CRATES= anyhow-1.0.40 \
getrandom-0.1.16 \
half-1.7.1 \
handlebars-3.5.4 \
+ hashbrown-0.9.1 \
hermit-abi-0.1.18 \
+ humansize-1.1.0 \
+ ident_case-1.0.1 \
+ indexmap-1.6.2 \
inotify-0.7.1 \
inotify-sys-0.1.5 \
instant-0.1.9 \
@@ -85,6 +100,7 @@ CARGO_CRATES= anyhow-1.0.40 \
mio-extras-2.0.6 \
miow-0.2.2 \
miow-0.3.7 \
+ natord-1.0.9 \
net2-0.2.37 \
notify-4.0.15 \
ntapi-0.3.6 \
@@ -103,6 +119,7 @@ CARGO_CRATES= anyhow-1.0.40 \
plotters-0.3.0 \
plotters-backend-0.3.0 \
plotters-svg-0.3.0 \
+ proc-macro-hack-0.5.19 \
proc-macro2-1.0.26 \
quick-error-2.0.0 \
quote-1.0.9 \
@@ -115,6 +132,7 @@ CARGO_CRATES= anyhow-1.0.40 \
regex-1.4.5 \
regex-automata-0.1.9 \
regex-syntax-0.6.23 \
+ rspec-1.0.0 \
rust-argon2-0.8.3 \
rustc_version-0.2.3 \
ryu-1.0.5 \
@@ -128,14 +146,24 @@ CARGO_CRATES= anyhow-1.0.40 \
serde_json-1.0.64 \
serde_yaml-0.8.17 \
sha-1-0.8.2 \
+ sha1-0.6.0 \
signal-hook-0.1.17 \
signal-hook-registry-1.3.0 \
slab-0.4.2 \
smallvec-1.6.1 \
+ standback-0.2.17 \
+ stdweb-0.4.20 \
+ stdweb-derive-0.5.3 \
+ stdweb-internal-macros-0.2.9 \
+ stdweb-internal-runtime-0.1.5 \
+ strsim-0.9.3 \
syn-1.0.68 \
termion-1.5.6 \
textwrap-0.11.0 \
time-0.1.44 \
+ time-0.2.26 \
+ time-macros-0.1.1 \
+ time-macros-impl-0.1.1 \
tinytemplate-1.2.1 \
tui-0.14.0 \
typenum-1.13.0 \