aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
Diffstat (limited to 'misc')
-rw-r--r--misc/bb/Makefile3
-rw-r--r--misc/callid/Makefile3
-rw-r--r--misc/clex/Makefile2
-rw-r--r--misc/cmatrix/Makefile3
-rw-r--r--misc/crosspad/Makefile3
-rw-r--r--misc/dtach/Makefile3
-rw-r--r--misc/dvorakng/Makefile3
-rw-r--r--misc/esniper/Makefile3
-rw-r--r--misc/gkx86info2/Makefile3
-rw-r--r--misc/gnome-osd/Makefile3
-rw-r--r--misc/hello/Makefile2
-rw-r--r--misc/lifelines/Makefile3
-rw-r--r--misc/mirmon/Makefile2
-rw-r--r--misc/mtail/Makefile3
-rw-r--r--misc/pdfmap/Makefile3
-rw-r--r--misc/ringtonetools/Makefile3
-rw-r--r--misc/rname/Makefile3
-rw-r--r--misc/salias/Makefile3
-rw-r--r--misc/tet/Makefile3
-rw-r--r--misc/tkman/Makefile2
20 files changed, 56 insertions, 0 deletions
diff --git a/misc/bb/Makefile b/misc/bb/Makefile
index 9518f3730a3b..94f4b63fa934 100644
--- a/misc/bb/Makefile
+++ b/misc/bb/Makefile
@@ -22,6 +22,9 @@ PLIST_FILES= bin/bb share/bb/bb.s3m share/bb/bb2.s3m share/bb/bb3.s3m
PLIST_DIRS= share/bb
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
pre-patch:
diff --git a/misc/callid/Makefile b/misc/callid/Makefile
index 91b565956951..5488711a49de 100644
--- a/misc/callid/Makefile
+++ b/misc/callid/Makefile
@@ -22,6 +22,9 @@ PORTDOCS= CHANGES README TODO make-db.mysql
RUN_DEPENDS+= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
pre-everything::
diff --git a/misc/clex/Makefile b/misc/clex/Makefile
index a8581238b8ff..5b4af169987d 100644
--- a/misc/clex/Makefile
+++ b/misc/clex/Makefile
@@ -28,6 +28,8 @@ post-patch:
@${REINPLACE_CMD} -e '18s,^,#include <stdio.h>,' \
${WRKSRC}/src/preview.c
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
diff --git a/misc/cmatrix/Makefile b/misc/cmatrix/Makefile
index 51c8206fc934..acc1eb70f513 100644
--- a/misc/cmatrix/Makefile
+++ b/misc/cmatrix/Makefile
@@ -18,6 +18,9 @@ PORTDOCS= ChangeLog README TODO
PLIST_FILES= bin/cmatrix
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
do-install:
diff --git a/misc/crosspad/Makefile b/misc/crosspad/Makefile
index 09e7784e14ad..38d8d2dc06b6 100644
--- a/misc/crosspad/Makefile
+++ b/misc/crosspad/Makefile
@@ -18,6 +18,9 @@ MAN1= crosspad2ps.1 crosspad2eps.1 crosspad2tgif.1 crosspad2idraw.1 \
DOCS= PROTOCOL README.english README.japanese
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-install:
diff --git a/misc/dtach/Makefile b/misc/dtach/Makefile
index 7dbbead909ad..1129a83a0cbf 100644
--- a/misc/dtach/Makefile
+++ b/misc/dtach/Makefile
@@ -18,6 +18,9 @@ PORTDOCS= README
PLIST_FILES= bin/${PORTNAME}
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
do-install:
diff --git a/misc/dvorakng/Makefile b/misc/dvorakng/Makefile
index 7125c1058895..7432086932a6 100644
--- a/misc/dvorakng/Makefile
+++ b/misc/dvorakng/Makefile
@@ -17,6 +17,9 @@ MAKE_ARGS= CC="${CC}" CXX="${CXX}" CFLAGS="${CFLAGS} ${CPPFLAGS}" \
CXXFLAGS="${CXXFLAGS} ${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
PLIST_FILES= bin/dvorakng
diff --git a/misc/esniper/Makefile b/misc/esniper/Makefile
index 1812891d56bb..90a8b0bce276 100644
--- a/misc/esniper/Makefile
+++ b/misc/esniper/Makefile
@@ -24,6 +24,9 @@ PLIST_FILES= bin/esniper
PORTEXAMPLES= sample_auction.txt sample_config.txt
NO_STAGE= yes
+
+OPTIONS_DEFINE= EXAMPLES
+
.include <bsd.port.options.mk>
post-install:
diff --git a/misc/gkx86info2/Makefile b/misc/gkx86info2/Makefile
index 98186a0a3cf1..02a33ab18ac3 100644
--- a/misc/gkx86info2/Makefile
+++ b/misc/gkx86info2/Makefile
@@ -21,6 +21,9 @@ USE_GNOME= gtk20
WRKSRC= ${WRKDIR}/gkx86info${PORTVERSION}
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
do-build:
diff --git a/misc/gnome-osd/Makefile b/misc/gnome-osd/Makefile
index 6e7bd4a2614f..91b695f504c1 100644
--- a/misc/gnome-osd/Makefile
+++ b/misc/gnome-osd/Makefile
@@ -24,6 +24,9 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-install:
diff --git a/misc/hello/Makefile b/misc/hello/Makefile
index 0857c16c8339..3df01682dbdf 100644
--- a/misc/hello/Makefile
+++ b/misc/hello/Makefile
@@ -16,6 +16,8 @@ GNU_CONFIGURE= YES
INFO= hello
+OPTIONS_DEFINE= NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/misc/lifelines/Makefile b/misc/lifelines/Makefile
index 4fc8c84365e6..eaad2f57a7ea 100644
--- a/misc/lifelines/Makefile
+++ b/misc/lifelines/Makefile
@@ -17,6 +17,9 @@ USES= bison iconv
MAN1= btedit.1 dbverify.1 llines.1
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
USES+= gettext
diff --git a/misc/mirmon/Makefile b/misc/mirmon/Makefile
index fec2c262392d..d272c00392b2 100644
--- a/misc/mirmon/Makefile
+++ b/misc/mirmon/Makefile
@@ -19,6 +19,8 @@ SUB_LIST= PREFIX=${PREFIX}
PLIST_FILES= bin/mirmon bin/probe
MAN1= mirmon.1
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ! ${PORT_OPTIONS:MDOCS}
diff --git a/misc/mtail/Makefile b/misc/mtail/Makefile
index 6c9601da4702..4363d6b7c11f 100644
--- a/misc/mtail/Makefile
+++ b/misc/mtail/Makefile
@@ -17,6 +17,9 @@ PORTDOCS= CHANGES LICENSE README
PORTEXAMPLES= mtailrc
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/misc/pdfmap/Makefile b/misc/pdfmap/Makefile
index fed018d93e2f..974d4daed961 100644
--- a/misc/pdfmap/Makefile
+++ b/misc/pdfmap/Makefile
@@ -21,6 +21,9 @@ USE_PYDISTUTILS= yes
DOCS= CREDITS NEWS README TODO doc/*.html
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
diff --git a/misc/ringtonetools/Makefile b/misc/ringtonetools/Makefile
index 50a49234141d..562267dfa3f2 100644
--- a/misc/ringtonetools/Makefile
+++ b/misc/ringtonetools/Makefile
@@ -14,6 +14,9 @@ RESTRICTED= no-commercial-use
MAKE_ARGS= CC="${CC}" FLAGS="${CFLAGS}"
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/misc/rname/Makefile b/misc/rname/Makefile
index 14a4612c0a2b..55a4351056fa 100644
--- a/misc/rname/Makefile
+++ b/misc/rname/Makefile
@@ -14,6 +14,9 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
USE_GMAKE= yes
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
diff --git a/misc/salias/Makefile b/misc/salias/Makefile
index d7272b060730..07844078aa7a 100644
--- a/misc/salias/Makefile
+++ b/misc/salias/Makefile
@@ -19,6 +19,9 @@ MAN1= salias.1
DOCS= NEWS README
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
diff --git a/misc/tet/Makefile b/misc/tet/Makefile
index 8cc3e67ce341..205e51ada411 100644
--- a/misc/tet/Makefile
+++ b/misc/tet/Makefile
@@ -24,6 +24,9 @@ PLIST= ${WRKDIR}/PLIST
TET_CONFIG_TARGET?= inet # options are `lite', `xti' and `inet'
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
diff --git a/misc/tkman/Makefile b/misc/tkman/Makefile
index 31a0bbe6141a..87e799a36a5d 100644
--- a/misc/tkman/Makefile
+++ b/misc/tkman/Makefile
@@ -22,6 +22,8 @@ MAKE_ARGS= WISH="${WISH}" \
manformat="{groff -Tlatin1 -te -mandoc}" \
manprint="{groff -mandoc -Tps -te -l}"
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch: