aboutsummaryrefslogtreecommitdiff
path: root/multimedia/audacious
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/audacious')
-rw-r--r--multimedia/audacious/Makefile19
-rw-r--r--multimedia/audacious/distinfo4
-rw-r--r--multimedia/audacious/files/patch-src-audacious-Makefile16
-rw-r--r--multimedia/audacious/files/patch-src-audacious-util.c14
-rw-r--r--multimedia/audacious/pkg-plist12
5 files changed, 40 insertions, 25 deletions
diff --git a/multimedia/audacious/Makefile b/multimedia/audacious/Makefile
index 42bac367b73b..d0e05f3455cb 100644
--- a/multimedia/audacious/Makefile
+++ b/multimedia/audacious/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= audacious
-PORTVERSION= 2.4.4
+PORTVERSION= 2.5.0
CATEGORIES= multimedia audio
MASTER_SITES= http://distfiles.atheme.org/
MASTER_SITE_SUBDIR=oliver
@@ -20,11 +20,10 @@ USE_GMAKE= yes
USE_XORG= x11 sm
USE_GNOME= gtk20 libglade2
USE_LDCONFIG= yes
-CONFIGURE_ARGS= --with-libintl-prefix=${LOCALBASE}
-#CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
-# LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
-MAN1= audacious2.1 audtool2.1
+MAN1= audacious.1 audtool.1
LIB_DEPENDS= mcs.1:${PORTSDIR}/devel/libmcs \
mowgli.2:${PORTSDIR}/devel/libmowgli \
@@ -35,6 +34,7 @@ PORTDOCS= README AUTHORS NEWS
OPTIONS= CHARSET "Build with automatic charset detection" off \
DBUS "Build with dbus support" on \
GNOME "Build with gconf support" off \
+ ICONV "Build with iconv support" on \
NLS "Native Language Support" on \
EXECINFO "Build with libexecinfo support" on \
SSE2 "Build with SSE2 instruction set" on
@@ -50,8 +50,8 @@ CONFIGURE_ARGS+=--disable-dbus
PLIST_SUB+= WITH_DBUS="@comment "
.endif
-.if defined(WITH_CHARSET)
-CONFIGURE_ARGS+=--enable-chardet
+.if !defined(WITH_CHARSET)
+CONFIGURE_ARGS+=--disable-chardet
.endif
.if defined(WITH_EXECINFO) || exists(${LOCALBASE}/lib/libexecinfo.so)
@@ -63,6 +63,10 @@ USE_GNOME+= gconf2
CONFIGURE_ARGS+=--enable-gconf
.endif
+.if defined(WITH_ICONV) || exists(${LOCALBASE}/lib/libiconv.so)
+USE_ICONV= yes
+.endif
+
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
CONFIGURE_ARGS+=--enable-nls
@@ -114,6 +118,5 @@ post-install:
@${ECHO_MSG} "ALL PRESETS will be stored in the gconf database."
@${ECHO_MSG} ""
.endif
-
.include <bsd.port.post.mk>
diff --git a/multimedia/audacious/distinfo b/multimedia/audacious/distinfo
index 89906032ece5..e8ebe0eac82a 100644
--- a/multimedia/audacious/distinfo
+++ b/multimedia/audacious/distinfo
@@ -1,2 +1,2 @@
-SHA256 (audacious-2.4.4.tgz) = 76f84038a0360da80aeaddd1ec23e5a55fee5a120abffce97c4609958cdb30e8
-SIZE (audacious-2.4.4.tgz) = 1344519
+SHA256 (audacious-2.5.0.tgz) = a4d7f6897df91f2d76bb6f388fc47d0d4aa1443fdb8dcf7a0c5debf80360c900
+SIZE (audacious-2.5.0.tgz) = 1224598
diff --git a/multimedia/audacious/files/patch-src-audacious-Makefile b/multimedia/audacious/files/patch-src-audacious-Makefile
index da2d0fb2702d..1cf90f3898ed 100644
--- a/multimedia/audacious/files/patch-src-audacious-Makefile
+++ b/multimedia/audacious/files/patch-src-audacious-Makefile
@@ -1,6 +1,6 @@
---- src/audacious/Makefile.orig 2010-08-26 01:04:25.000000000 +0200
-+++ src/audacious/Makefile 2010-09-09 11:07:04.000000000 +0200
-@@ -91,15 +91,16 @@
+--- src/audacious/Makefile.orig 2011-04-16 18:09:10.000000000 +0200
++++ src/audacious/Makefile 2011-04-25 11:44:28.000000000 +0200
+@@ -93,15 +93,16 @@
include ../../buildsys.mk
ifeq ($(USE_DBUS),yes)
@@ -19,19 +19,19 @@
${MOWGLI_CFLAGS} \
${GLIB_CFLAGS} \
${GTHREAD_CFLAGS} \
-@@ -116,7 +117,7 @@
- -I.. -I../.. \
- -I./intl
+@@ -118,7 +119,7 @@
+ ${LIBGUESS_CFLAGS} \
+ -I.. -I../..
-LIBS += ${LDADD} \
+LIBS += \
-lm \
-L../libaudcore -laudcore \
-L../libaudgui -laudgui \
-@@ -130,7 +131,8 @@
- ${MOWGLI_LIBS} \
+@@ -133,7 +134,8 @@
${LIBMCS_LIBS} \
${REGEX_LIBS} \
+ ${PTHREAD_LIBS} \
- ${LIBGUESS_LIBS}
+ ${LIBGUESS_LIBS} \
+ ${LDADD}
diff --git a/multimedia/audacious/files/patch-src-audacious-util.c b/multimedia/audacious/files/patch-src-audacious-util.c
new file mode 100644
index 000000000000..ab7c2ac14316
--- /dev/null
+++ b/multimedia/audacious/files/patch-src-audacious-util.c
@@ -0,0 +1,14 @@
+--- src/audacious/util.c.orig 2011-04-23 14:49:07.000000000 +0200
++++ src/audacious/util.c 2011-04-23 14:50:08.000000000 +0200
+@@ -174,9 +174,9 @@
+ return NULL;
+ }
+ #else
+- if ((len = readlink ("/proc/self/exe", buf, sizeof buf)) < 0)
++ if ((len = readlink ("/proc/curproc/file", buf, sizeof buf)) < 0)
+ {
+- fprintf (stderr, "Cannot access /proc/self/exe: %s.\n", strerror (errno));
++ fprintf (stderr, "Cannot access /proc/curproc/file: %s.\n", strerror (errno));
+ return NULL;
+ }
+ #endif
diff --git a/multimedia/audacious/pkg-plist b/multimedia/audacious/pkg-plist
index a1606e301757..5112e144707f 100644
--- a/multimedia/audacious/pkg-plist
+++ b/multimedia/audacious/pkg-plist
@@ -1,9 +1,5 @@
-man/man1/audacious.1
-man/man1/audtool.1
bin/audacious
-bin/audacious2
%%WITH_DBUS%%bin/audtool
-%%WITH_DBUS%%bin/audtool2
%%WITH_DBUS%%include/audacious/audctrl.h
include/audacious/audconfig.h
include/audacious/configdb.h
@@ -23,6 +19,8 @@ include/audacious/configdb-api.h
include/audacious/debug.h
include/audacious/drct.h
include/audacious/drct-api.h
+include/audacious/glib-compat.h
+include/audacious/gtk-compat.h
include/audacious/misc.h
include/audacious/misc-api.h
include/audacious/playlist.h
@@ -37,7 +35,6 @@ include/libaudcore/stringpool.h
include/libaudcore/tuple.h
include/libaudcore/tuple_compiler.h
include/libaudcore/tuple_formatter.h
-include/libaudcore/log.h
include/libaudcore/md5.h
include/libaudcore/vfs.h
include/libaudcore/vfs_buffer.h
@@ -47,6 +44,7 @@ include/libaudcore/hook.h
include/libaudcore/vfs_async.h
include/libaudgui/libaudgui.h
include/libaudgui/libaudgui-gtk.h
+include/libaudgui/list.h
%%WITH_DBUS%%lib/libaudclient.so
%%WITH_DBUS%%lib/libaudclient.so.2
%%WITH_DBUS%%lib/libaudclient.so.2.0.0
@@ -61,8 +59,9 @@ lib/libaudtag.so.1
lib/libaudtag.so.1.0.0
libdata/pkgconfig/audacious.pc
libdata/pkgconfig/audclient.pc
-share/applications/audacious2.desktop
+share/applications/audacious.desktop
%%DATADIR%%/images/about-logo.png
+%%DATADIR%%/images/album.png
%%DATADIR%%/images/audacious_eq.xpm
%%DATADIR%%/images/audacious_playlist.xpm
%%DATADIR%%/images/appearance.png
@@ -73,7 +72,6 @@ share/applications/audacious2.desktop
%%DATADIR%%/images/menu_playlist.png
%%DATADIR%%/images/menu_plugin.png
%%DATADIR%%/images/menu_queue_toggle.png
-%%DATADIR%%/images/playback.png
%%DATADIR%%/images/playlist.png
%%DATADIR%%/images/plugins.png
%%DATADIR%%/images/replay_gain.png