aboutsummaryrefslogtreecommitdiff
path: root/multimedia/bcmatroska2
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/bcmatroska2')
-rw-r--r--multimedia/bcmatroska2/Makefile16
-rw-r--r--multimedia/bcmatroska2/distinfo3
-rw-r--r--multimedia/bcmatroska2/files/patch-corec-corec-helpers-file-file_libc.c11
-rw-r--r--multimedia/bcmatroska2/pkg-descr3
-rw-r--r--multimedia/bcmatroska2/pkg-plist43
5 files changed, 76 insertions, 0 deletions
diff --git a/multimedia/bcmatroska2/Makefile b/multimedia/bcmatroska2/Makefile
new file mode 100644
index 000000000000..eee40b87ee84
--- /dev/null
+++ b/multimedia/bcmatroska2/Makefile
@@ -0,0 +1,16 @@
+# $FreeBSD$
+
+PORTNAME= bcmatroska2
+PORTVERSION= 0.23
+CATEGORIES= multimedia
+MASTER_SITES= https://www.linphone.org/releases/sources/bcmatroska2/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Belledonne Communications Matroska media container support
+
+USES= cmake:outsource
+USE_LDCONFIG= yes
+
+CMAKE_ARGS= -DENABLE_STATIC=NO
+
+.include <bsd.port.mk>
diff --git a/multimedia/bcmatroska2/distinfo b/multimedia/bcmatroska2/distinfo
new file mode 100644
index 000000000000..1591e626483d
--- /dev/null
+++ b/multimedia/bcmatroska2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1529855371
+SHA256 (bcmatroska2-0.23.tar.gz) = 2540e2d39785004060688218df2d33ddefc2561f6cf1fcdd4d2840e8c8a41ba8
+SIZE (bcmatroska2-0.23.tar.gz) = 959058
diff --git a/multimedia/bcmatroska2/files/patch-corec-corec-helpers-file-file_libc.c b/multimedia/bcmatroska2/files/patch-corec-corec-helpers-file-file_libc.c
new file mode 100644
index 000000000000..8b2c85260201
--- /dev/null
+++ b/multimedia/bcmatroska2/files/patch-corec-corec-helpers-file-file_libc.c
@@ -0,0 +1,11 @@
+--- corec/corec/helpers/file/file_libc.c.orig 2017-07-20 13:52:29 UTC
++++ corec/corec/helpers/file/file_libc.c
+@@ -40,7 +40,7 @@
+ #include <unistd.h>
+ #include <dirent.h>
+ #include <errno.h>
+-#if defined(TARGET_OSX)
++#if defined(TARGET_OSX) || defined(__FreeBSD__)
+ #include <sys/mount.h>
+ #elif defined(TARGET_QNX)
+ #include <sys/statvfs.h>
diff --git a/multimedia/bcmatroska2/pkg-descr b/multimedia/bcmatroska2/pkg-descr
new file mode 100644
index 000000000000..5d52f78c70b6
--- /dev/null
+++ b/multimedia/bcmatroska2/pkg-descr
@@ -0,0 +1,3 @@
+This library provides support for Matroska, a media container format.
+
+WWW: https://www.linphone.org/
diff --git a/multimedia/bcmatroska2/pkg-plist b/multimedia/bcmatroska2/pkg-plist
new file mode 100644
index 000000000000..621a87a1b307
--- /dev/null
+++ b/multimedia/bcmatroska2/pkg-plist
@@ -0,0 +1,43 @@
+include/corec/array/array.h
+include/corec/banned.h
+include/corec/confhelper.h
+include/corec/config.h
+include/corec/corec.h
+include/corec/err.h
+include/corec/helper.h
+include/corec/helpers/charconvert/charconvert.h
+include/corec/helpers/date/date.h
+include/corec/helpers/file/file.h
+include/corec/helpers/file/streams.h
+include/corec/helpers/md5/md5.h
+include/corec/helpers/parser/buffer.h
+include/corec/helpers/parser/dataheap.h
+include/corec/helpers/parser/hotkey.h
+include/corec/helpers/parser/nodelookup.h
+include/corec/helpers/parser/parser.h
+include/corec/helpers/parser/strtab.h
+include/corec/helpers/parser/strtypes.h
+include/corec/helpers/parser/urlpart.h
+include/corec/helpers/system/ccsystem.h
+include/corec/memalloc.h
+include/corec/memheap.h
+include/corec/multithread/multithread.h
+include/corec/node/node.h
+include/corec/node/node_internal.h
+include/corec/node/nodebase.h
+include/corec/node/nodetools.h
+include/corec/node/nodetree.h
+include/corec/portab.h
+include/corec/str/str.h
+include/ebml/ebml.h
+include/ebml/ebml_internal.h
+include/matroska/matroska.h
+include/matroska/matroska_internal.h
+include/matroska/matroska_sem.h
+lib/libbcmatroska2.so
+lib/libbcmatroska2.so.0
+lib/libbcmatroska2.so.0.0.0
+%%DATADIR%%/cmake/BcMatroska2Config.cmake
+%%DATADIR%%/cmake/BcMatroska2ConfigVersion.cmake
+%%DATADIR%%/cmake/BcMatroska2Targets-%%CMAKE_BUILD_TYPE%%.cmake
+%%DATADIR%%/cmake/BcMatroska2Targets.cmake