aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gnome-subtitles/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/gnome-subtitles/Makefile')
-rw-r--r--multimedia/gnome-subtitles/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/multimedia/gnome-subtitles/Makefile b/multimedia/gnome-subtitles/Makefile
index 183ee17be5b6..155d5f4c525b 100644
--- a/multimedia/gnome-subtitles/Makefile
+++ b/multimedia/gnome-subtitles/Makefile
@@ -2,12 +2,11 @@
# $FreeBSD$
PORTNAME= gnome-subtitles
-PORTVERSION= 1.2
-PORTREVISION= 1
+PORTVERSION= 1.3
CATEGORIES= multimedia
MASTER_SITES= SF
-MAINTAINER= armin@frozen-zone.org
+MAINTAINER= sperber@FreeBSD.org
COMMENT= Subtitle editor with video preview
LICENSE= GPLv2
@@ -15,22 +14,19 @@ LICENSE= GPLv2
LIB_DEPENDS= libenchant.so:${PORTSDIR}/textproc/enchant \
libgtkspell.so:${PORTSDIR}/textproc/gtkspell
-USES= gmake mono pkgconfig
+USES= gmake mono pkgconfig libtool desktop-file-utils
USE_GNOME= gnomeprefix gtksharp20 gnomesharp20 gnomedocutils
-USE_GSTREAMER= yes
+USE_GSTREAMER1= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
GCONF_SCHEMAS= gnome-subtitles.schemas
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
+MAKE_JOBS_UNSAFE=yes
USE_LDCONFIG= ${PREFIX}/lib/gnome-subtitles
-MAN1= gnome-subtitles.1
-
-NO_STAGE= yes
-
OPTIONS_DEFINE= NLS
.include <bsd.port.options.mk>
@@ -43,4 +39,7 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/gnome-subtitles/libgstreamer_playbin.so
+
.include <bsd.port.mk>