aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer-plugins80/Makefile.common
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/gstreamer-plugins80/Makefile.common')
-rw-r--r--multimedia/gstreamer-plugins80/Makefile.common20
1 files changed, 14 insertions, 6 deletions
diff --git a/multimedia/gstreamer-plugins80/Makefile.common b/multimedia/gstreamer-plugins80/Makefile.common
index 5c1403e7583d..4e4ef9a5dfd7 100644
--- a/multimedia/gstreamer-plugins80/Makefile.common
+++ b/multimedia/gstreamer-plugins80/Makefile.common
@@ -75,6 +75,7 @@ GST_ALL_PLUGINS= \
vorbis \
vorbistest \
wavpack \
+ x264 \
xvid
# Disable all plugins by default\
@@ -104,14 +105,15 @@ CONFIGURE_ARGS+=--disable-tests \
--enable-xshm \
--enable-xvideo
-.if (${ARCH} == "i386")
-BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
-CONFIGURE_ARGS+=--enable-spc
-PLIST_SUB+= SPC=""
-.else
+# spc is broken a the moment
+#.if (${ARCH} == "i386")
+#BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
+#CONFIGURE_ARGS+=--enable-spc
+#PLIST_SUB+= SPC=""
+#.else
CONFIGURE_ARGS+=--disable-spc
PLIST_SUB+= SPC="@comment "
-.endif
+#.endif
.if ${GST_PLUGIN}!="base"
@@ -463,6 +465,12 @@ LIB_DEPENDS+= vorbisidec.1:${PORTSDIR}/audio/libtremor
LIB_DEPENDS+= wavpack.0:${PORTSDIR}/audio/wavpack
.endif
+# x264
+.if ${GST_PLUGIN}=="x264"
+LIB_DEPENDS+= x264.1:${PORTSDIR}/multimedia/x264
+PLIST_FILES= ${GST_LIB_DIR}/libx264.so
+.endif
+
# xvid
.if ${GST_PLUGIN}=="xvid"
LIB_DEPENDS+= xvidcore.4:${PORTSDIR}/multimedia/xvid