aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer1-plugins/Makefile.common
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/gstreamer1-plugins/Makefile.common')
-rw-r--r--multimedia/gstreamer1-plugins/Makefile.common8
1 files changed, 7 insertions, 1 deletions
diff --git a/multimedia/gstreamer1-plugins/Makefile.common b/multimedia/gstreamer1-plugins/Makefile.common
index 527333e04db7..bf2053376550 100644
--- a/multimedia/gstreamer1-plugins/Makefile.common
+++ b/multimedia/gstreamer1-plugins/Makefile.common
@@ -44,6 +44,7 @@ BAD_GST_ALL_PLUGINS+= \
modplug \
mpeg2enc \
mplex \
+ msdk \
musepack \
neon \
ofa \
@@ -83,7 +84,6 @@ BAD_GST_NON_PLUGINS= \
--disable-directfb \
--disable-direct3d \
--disable-directsound \
- --disable-msdk \
--disable-nvenc \
--disable-nvdec \
--disable-sbc \
@@ -361,6 +361,12 @@ gst_mplex_LIB_DEPENDS= libmplex2.so:multimedia/mjpegtools
# mpg123
gst_mpg123_LIB_DEPENDS= libmpg123.so:audio/mpg123
+# msdk
+gst_msdk_LIB_DEPENDS= libgudev-1.0.so:devel/libgudev \
+ libmfx.so:multimedia/intel-media-sdk \
+ libva-drm.so:multimedia/libva
+gst_msdk_GST_PLUGIN_DIR= sys/msdk
+
# musepack
gst_musepack_LIB_DEPENDS=libmpcdec.so:audio/musepack