aboutsummaryrefslogtreecommitdiff
path: root/multimedia/librtmp/files
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/librtmp/files')
-rw-r--r--multimedia/librtmp/files/patch-librtmp-Makefile84
-rw-r--r--multimedia/librtmp/files/patch-librtmp-dh.h116
-rw-r--r--multimedia/librtmp/files/patch-librtmp-handshake.h100
-rw-r--r--multimedia/librtmp/files/patch-librtmp-hashswf.c94
-rw-r--r--multimedia/librtmp/files/patch-librtmp-librtmp.pc.in11
5 files changed, 0 insertions, 405 deletions
diff --git a/multimedia/librtmp/files/patch-librtmp-Makefile b/multimedia/librtmp/files/patch-librtmp-Makefile
deleted file mode 100644
index c3337a8b97ed..000000000000
--- a/multimedia/librtmp/files/patch-librtmp-Makefile
+++ /dev/null
@@ -1,84 +0,0 @@
---- librtmp/Makefile.orig 2019-03-30 21:33:00 UTC
-+++ librtmp/Makefile
-@@ -1,19 +1,21 @@ VERSION=v2.4
- VERSION=v2.4
-
--prefix=/usr/local
-+prefix=$(PREFIX)
-
- incdir=$(prefix)/include/librtmp
- bindir=$(prefix)/bin
- libdir=$(prefix)/lib
--mandir=$(prefix)/man
-+libdatadir=$(prefix)/libdata
-+mandir=$(prefix)/share/man
- BINDIR=$(DESTDIR)$(bindir)
- INCDIR=$(DESTDIR)$(incdir)
- LIBDIR=$(DESTDIR)$(libdir)
-+LIBDATADIR=$(DESTDIR)$(libdatadir)
- MANDIR=$(DESTDIR)$(mandir)
-
--CC=$(CROSS_COMPILE)gcc
--LD=$(CROSS_COMPILE)ld
--AR=$(CROSS_COMPILE)ar
-+CC?=$(CROSS_COMPILE)gcc
-+LD?=$(CROSS_COMPILE)ld
-+AR?=$(CROSS_COMPILE)ar
-
- SYS=posix
- CRYPTO=OPENSSL
-@@ -23,14 +25,14 @@ REQ_GNUTLS=gnutls,hogweed,nettle
- DEF_GNUTLS=-DUSE_GNUTLS
- DEF_=-DNO_CRYPTO
- REQ_GNUTLS=gnutls,hogweed,nettle
--REQ_OPENSSL=libssl,libcrypto
-+#REQ_OPENSSL=libssl,libcrypto
- PUB_GNUTLS=-lgmp
- LIBZ=-lz
- LIBS_posix=
- LIBS_darwin=
- LIBS_mingw=-lws2_32 -lwinmm -lgdi32
- LIB_GNUTLS=-lgnutls -lhogweed -lnettle -lgmp $(LIBZ)
--LIB_OPENSSL=-lssl -lcrypto $(LIBZ)
-+LIB_OPENSSL=-L$(OPENSSLLIB) -lssl -lcrypto $(LIBZ)
- LIB_POLARSSL=-lpolarssl $(LIBZ)
- PRIVATE_LIBS=$(LIBS_$(SYS))
- CRYPTO_LIB=$(LIB_$(CRYPTO)) $(PRIVATE_LIBS)
-@@ -74,8 +76,9 @@ OPT=-O2
-
- DEF=-DRTMPDUMP_VERSION=\"$(VERSION)\" $(CRYPTO_DEF) $(XDEF)
- OPT=-O2
--CFLAGS=-Wall $(XCFLAGS) $(INC) $(DEF) $(OPT) $(SO_DEF)
--LDFLAGS=$(XLDFLAGS)
-+#CFLAGS=-Wall $(XCFLAGS) $(INC) $(DEF) $(OPT) $(SO_DEF)
-+CFLAGS+=$(DEF) $(SO_DEF)
-+#LDFLAGS=$(XLDFLAGS)
-
-
- OBJS=rtmp.o log.o amf.o hashswf.o parseurl.o
-@@ -102,20 +105,22 @@ librtmp.pc: librtmp.pc.in Makefile
- sed -e "s;@prefix@;$(prefix);" -e "s;@libdir@;$(libdir);" \
- -e "s;@VERSION@;$(VERSION);" \
- -e "s;@CRYPTO_REQ@;$(CRYPTO_REQ);" \
-+ -e "s;@OPENSSLLIB@;$(OPENSSLLIB);" \
-+ -e "s;@OPENSSLINC@;$(OPENSSLINC);" \
- -e "s;@PUBLIC_LIBS@;$(PUBLIC_LIBS);" \
- -e "s;@PRIVATE_LIBS@;$(PRIVATE_LIBS);" librtmp.pc.in > $@
-
- install: install_base $(SO_INST)
-
- install_base: librtmp.a librtmp.pc
-- -mkdir -p $(INCDIR) $(LIBDIR)/pkgconfig $(MANDIR)/man3 $(SODIR)
-+ -mkdir -p $(INCDIR) $(LIBDATADIR)/pkgconfig $(MANDIR)/man3 $(SODIR)
- cp amf.h http.h log.h rtmp.h $(INCDIR)
- cp librtmp.a $(LIBDIR)
-- cp librtmp.pc $(LIBDIR)/pkgconfig
-+ cp librtmp.pc $(LIBDATADIR)/pkgconfig
- cp librtmp.3 $(MANDIR)/man3
-
- install_so: librtmp$(SO_EXT)
-- cp librtmp$(SO_EXT) $(SODIR)
-+ ${BSD_INSTALL_LIB} librtmp$(SO_EXT) $(SODIR)
- $(INSTALL_IMPLIB)
- cd $(SODIR); ln -sf librtmp$(SO_EXT) librtmp.$(SOX)
-
diff --git a/multimedia/librtmp/files/patch-librtmp-dh.h b/multimedia/librtmp/files/patch-librtmp-dh.h
deleted file mode 100644
index 6f6bbd740da3..000000000000
--- a/multimedia/librtmp/files/patch-librtmp-dh.h
+++ /dev/null
@@ -1,116 +0,0 @@
---- librtmp/dh.h.orig 2016-02-29 01:15:13 UTC
-+++ librtmp/dh.h
-@@ -194,7 +194,7 @@ typedef BIGNUM * MP_t;
-
- /* RFC 2631, Section 2.1.5, http://www.ietf.org/rfc/rfc2631.txt */
- static int
--isValidPublicKey(MP_t y, MP_t p, MP_t q)
-+isValidPublicKey(const MP_t y, const MP_t p, const MP_t q)
- {
- int ret = TRUE;
- MP_t bn;
-@@ -253,20 +253,43 @@ DHInit(int nKeyBits)
- if (!dh)
- goto failed;
-
-+#if !defined(USE_OPENSSL) || defined(LIBRESSL_VERSION_NUMBER) || !defined(OPENSSL_VERSION_NUMBER) || OPENSSL_VERSION_NUMBER < 0x10100000L
- MP_new(dh->g);
-
- if (!dh->g)
- goto failed;
-+#else
-+ BIGNUM *g;
-
-+ MP_new(g);
-+ if (g == NULL)
-+ goto failed;
-+#endif
-+
-+#if !defined(USE_OPENSSL) || defined(LIBRESSL_VERSION_NUMBER) || !defined(OPENSSL_VERSION_NUMBER) || OPENSSL_VERSION_NUMBER < 0x10100000L
- MP_gethex(dh->p, P1024, res); /* prime P1024, see dhgroups.h */
-+#else
-+ const BIGNUM *p = DH_get0_p(dh);
-+
-+ MP_gethex(p, P1024, res); /* prime P1024, see dhgroups.h */
-+#endif
- if (!res)
- {
- goto failed;
- }
-
-+#if !defined(USE_OPENSSL) || defined(LIBRESSL_VERSION_NUMBER) || !defined(OPENSSL_VERSION_NUMBER) || OPENSSL_VERSION_NUMBER < 0x10100000L
- MP_set_w(dh->g, 2); /* base 2 */
-+#else
-+ MP_set_w(g, 2); /* base 2 */
-+ DH_set0_pqg(dh, p, NULL, g);
-+#endif
-
-+#if !defined(USE_OPENSSL) || defined(LIBRESSL_VERSION_NUMBER) || !defined(OPENSSL_VERSION_NUMBER) || OPENSSL_VERSION_NUMBER < 0x10100000L
- dh->length = nKeyBits;
-+#else
-+ DH_set_length(dh, nKeyBits);
-+#endif
- return dh;
-
- failed:
-@@ -293,12 +316,20 @@ DHGenerateKey(MDH *dh)
- MP_gethex(q1, Q1024, res);
- assert(res);
-
-+#if !defined(USE_OPENSSL) || defined(LIBRESSL_VERSION_NUMBER) || !defined(OPENSSL_VERSION_NUMBER) || OPENSSL_VERSION_NUMBER < 0x10100000L
- res = isValidPublicKey(dh->pub_key, dh->p, q1);
-+#else
-+ res = isValidPublicKey(DH_get0_pub_key(dh), DH_get0_p(dh), q1);
-+#endif
- if (!res)
- {
-+#if !defined(USE_OPENSSL) || defined(LIBRESSL_VERSION_NUMBER) || !defined(OPENSSL_VERSION_NUMBER) || OPENSSL_VERSION_NUMBER < 0x10100000L
- MP_free(dh->pub_key);
- MP_free(dh->priv_key);
- dh->pub_key = dh->priv_key = 0;
-+#else
-+ DH_set0_key(dh, NULL, NULL);
-+#endif
- }
-
- MP_free(q1);
-@@ -314,15 +345,27 @@ static int
- DHGetPublicKey(MDH *dh, uint8_t *pubkey, size_t nPubkeyLen)
- {
- int len;
-+#if !defined(USE_OPENSSL) || defined(LIBRESSL_VERSION_NUMBER) || !defined(OPENSSL_VERSION_NUMBER) || OPENSSL_VERSION_NUMBER < 0x10100000L
- if (!dh || !dh->pub_key)
-+#else
-+ if (!dh || !DH_get0_pub_key(dh))
-+#endif
- return 0;
-
-+#if !defined(USE_OPENSSL) || defined(LIBRESSL_VERSION_NUMBER) || !defined(OPENSSL_VERSION_NUMBER) || OPENSSL_VERSION_NUMBER < 0x10100000L
- len = MP_bytes(dh->pub_key);
-+#else
-+ len = MP_bytes(DH_get0_pub_key(dh));
-+#endif
- if (len <= 0 || len > (int) nPubkeyLen)
- return 0;
-
- memset(pubkey, 0, nPubkeyLen);
-+#if !defined(USE_OPENSSL) || defined(LIBRESSL_VERSION_NUMBER) || !defined(OPENSSL_VERSION_NUMBER) || OPENSSL_VERSION_NUMBER < 0x10100000L
- MP_setbin(dh->pub_key, pubkey + (nPubkeyLen - len), len);
-+#else
-+ MP_setbin(DH_get0_pub_key(dh), pubkey + (nPubkeyLen - len), len);
-+#endif
- return 1;
- }
-
-@@ -364,7 +407,11 @@ DHComputeSharedSecretKey(MDH *dh, uint8_
- MP_gethex(q1, Q1024, len);
- assert(len);
-
-+#if !defined(USE_OPENSSL) || defined(LIBRESSL_VERSION_NUMBER) || !defined(OPENSSL_VERSION_NUMBER) || OPENSSL_VERSION_NUMBER < 0x10100000L
- if (isValidPublicKey(pubkeyBn, dh->p, q1))
-+#else
-+ if (isValidPublicKey(pubkeyBn, DH_get0_p(dh), q1))
-+#endif
- res = MDH_compute_key(secret, nPubkeyLen, pubkeyBn, dh);
- else
- res = -1;
diff --git a/multimedia/librtmp/files/patch-librtmp-handshake.h b/multimedia/librtmp/files/patch-librtmp-handshake.h
deleted file mode 100644
index 0cb645c1f3e4..000000000000
--- a/multimedia/librtmp/files/patch-librtmp-handshake.h
+++ /dev/null
@@ -1,100 +0,0 @@
---- librtmp/handshake.h.orig 2016-02-29 01:15:13 UTC
-+++ librtmp/handshake.h
-@@ -31,9 +31,13 @@
- #define SHA256_DIGEST_LENGTH 32
- #endif
- #define HMAC_CTX sha2_context
--#define HMAC_setup(ctx, key, len) sha2_hmac_starts(&ctx, (unsigned char *)key, len, 0)
--#define HMAC_crunch(ctx, buf, len) sha2_hmac_update(&ctx, buf, len)
--#define HMAC_finish(ctx, dig, dlen) dlen = SHA256_DIGEST_LENGTH; sha2_hmac_finish(&ctx, dig)
-+#define HMAC_setup(ctx, key, len) do { \
-+ if (ctx == NULL) \
-+ ctx = calloc(1, sizeof(*ctx)); \
-+ sha2_hmac_starts(ctx, (unsigned char *)key, len, 0); \
-+ } while (0)
-+#define HMAC_crunch(ctx, buf, len) sha2_hmac_update(ctx, buf, len)
-+#define HMAC_finish(ctx, dig, dlen) dlen = SHA256_DIGEST_LENGTH; sha2_hmac_finish(ctx, dig)
-
- typedef arc4_context * RC4_handle;
- #define RC4_alloc(h) *h = malloc(sizeof(arc4_context))
-@@ -50,10 +54,17 @@ typedef arc4_context * RC4_handle;
- #endif
- #undef HMAC_CTX
- #define HMAC_CTX struct hmac_sha256_ctx
--#define HMAC_setup(ctx, key, len) hmac_sha256_set_key(&ctx, len, key)
--#define HMAC_crunch(ctx, buf, len) hmac_sha256_update(&ctx, len, buf)
--#define HMAC_finish(ctx, dig, dlen) dlen = SHA256_DIGEST_LENGTH; hmac_sha256_digest(&ctx, SHA256_DIGEST_LENGTH, dig)
--#define HMAC_close(ctx)
-+#define HMAC_setup(ctx, key, len) do { \
-+ if (ctx == NULL) \
-+ ctx = calloc(1, sizeof(*ctx)); \
-+ hmac_sha256_set_key(ctx, len, key); \
-+ } while (0)
-+#define HMAC_crunch(ctx, buf, len) hmac_sha256_update(ctx, len, buf)
-+#define HMAC_finish(ctx, dig, dlen) dlen = SHA256_DIGEST_LENGTH; hmac_sha256_digest(ctx, SHA256_DIGEST_LENGTH, dig)
-+#define HMAC_close(ctx) do { \
-+ free(ctx); \
-+ ctx = NULL; \
-+ } while (0)
-
- typedef struct arcfour_ctx* RC4_handle;
- #define RC4_alloc(h) *h = malloc(sizeof(struct arcfour_ctx))
-@@ -69,9 +80,37 @@ typedef struct arcfour_ctx* RC4_handle;
- #if OPENSSL_VERSION_NUMBER < 0x0090800 || !defined(SHA256_DIGEST_LENGTH)
- #error Your OpenSSL is too old, need 0.9.8 or newer with SHA256
- #endif
--#define HMAC_setup(ctx, key, len) HMAC_CTX_init(&ctx); HMAC_Init_ex(&ctx, key, len, EVP_sha256(), 0)
--#define HMAC_crunch(ctx, buf, len) HMAC_Update(&ctx, buf, len)
--#define HMAC_finish(ctx, dig, dlen) HMAC_Final(&ctx, dig, &dlen); HMAC_CTX_cleanup(&ctx)
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
-+#define HMAC_setup(ctx, key, len) do { \
-+ if (ctx == NULL) \
-+ ctx = calloc(1, sizeof(*ctx)); \
-+ HMAC_CTX_init(ctx); \
-+ HMAC_Init_ex(ctx, key, len, EVP_sha256(), 0); \
-+ } while (0)
-+#else
-+#define HMAC_setup(ctx, key, len) do { \
-+ if (ctx == NULL) \
-+ ctx = HMAC_CTX_new(); \
-+ else \
-+ HMAC_CTX_reset(ctx); \
-+ HMAC_Init_ex(ctx, key, len, EVP_sha256(), 0); \
-+ } while (0)
-+#endif
-+#define HMAC_crunch(ctx, buf, len) HMAC_Update(ctx, buf, len)
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
-+#define HMAC_finish(ctx, dig, dlen) do { \
-+ HMAC_Final(ctx, dig, &dlen); \
-+ HMAC_CTX_cleanup(ctx); \
-+ free(ctx); \
-+ ctx = NULL; \
-+ } while (0)
-+#else
-+#define HMAC_finish(ctx, dig, dlen) do { \
-+ HMAC_Final(ctx, dig, &dlen); \
-+ HMAC_CTX_free(ctx); \
-+ ctx = NULL; \
-+ } while (0)
-+#endif
-
- typedef RC4_KEY * RC4_handle;
- #define RC4_alloc(h) *h = malloc(sizeof(RC4_KEY))
-@@ -117,7 +156,7 @@ static void InitRC4Encryption
- {
- uint8_t digest[SHA256_DIGEST_LENGTH];
- unsigned int digestLen = 0;
-- HMAC_CTX ctx;
-+ HMAC_CTX *ctx = NULL;
-
- RC4_alloc(rc4keyIn);
- RC4_alloc(rc4keyOut);
-@@ -266,7 +305,7 @@ HMACsha256(const uint8_t *message, size_
- size_t keylen, uint8_t *digest)
- {
- unsigned int digestLen;
-- HMAC_CTX ctx;
-+ HMAC_CTX *ctx = NULL;
-
- HMAC_setup(ctx, key, keylen);
- HMAC_crunch(ctx, message, messageLen);
diff --git a/multimedia/librtmp/files/patch-librtmp-hashswf.c b/multimedia/librtmp/files/patch-librtmp-hashswf.c
deleted file mode 100644
index 2ee5b412ab45..000000000000
--- a/multimedia/librtmp/files/patch-librtmp-hashswf.c
+++ /dev/null
@@ -1,94 +0,0 @@
---- librtmp/hashswf.c.orig 2019-03-30 21:33:00 UTC
-+++ librtmp/hashswf.c
-@@ -37,10 +37,17 @@
- #define SHA256_DIGEST_LENGTH 32
- #endif
- #define HMAC_CTX sha2_context
--#define HMAC_setup(ctx, key, len) sha2_hmac_starts(&ctx, (unsigned char *)key, len, 0)
--#define HMAC_crunch(ctx, buf, len) sha2_hmac_update(&ctx, buf, len)
--#define HMAC_finish(ctx, dig, dlen) dlen = SHA256_DIGEST_LENGTH; sha2_hmac_finish(&ctx, dig)
--#define HMAC_close(ctx)
-+#define HMAC_setup(ctx, key, len) do { \
-+ if (ctx == NULL) \
-+ ctx = calloc(1, sizeof(*ctx)); \
-+ sha2_hmac_starts(ctx, (unsigned char *)key, len, 0); \
-+ } while (0);
-+#define HMAC_crunch(ctx, buf, len) sha2_hmac_update(ctx, buf, len)
-+#define HMAC_finish(ctx, dig, dlen) dlen = SHA256_DIGEST_LENGTH; sha2_hmac_finish(ctx, dig)
-+#define HMAC_close(ctx) do { \
-+ free(ctx); \
-+ ctx = NULL; \
-+ } while (0)
- #elif defined(USE_GNUTLS)
- #include <nettle/hmac.h>
- #ifndef SHA256_DIGEST_LENGTH
-@@ -48,20 +55,52 @@
- #endif
- #undef HMAC_CTX
- #define HMAC_CTX struct hmac_sha256_ctx
--#define HMAC_setup(ctx, key, len) hmac_sha256_set_key(&ctx, len, key)
--#define HMAC_crunch(ctx, buf, len) hmac_sha256_update(&ctx, len, buf)
--#define HMAC_finish(ctx, dig, dlen) dlen = SHA256_DIGEST_LENGTH; hmac_sha256_digest(&ctx, SHA256_DIGEST_LENGTH, dig)
--#define HMAC_close(ctx)
-+#define HMAC_setup(ctx, key, len) do { \
-+ if (ctx == NULL) \
-+ ctx = calloc(1, sizeof(*ctx)); \
-+ hmac_sha256_set_key(ctx, len, key); \
-+ } while (0)
-+#define HMAC_crunch(ctx, buf, len) hmac_sha256_update(ctx, len, buf)
-+#define HMAC_finish(ctx, dig, dlen) dlen = SHA256_DIGEST_LENGTH; hmac_sha256_digest(ctx, SHA256_DIGEST_LENGTH, dig)
-+#define HMAC_close(ctx) do { \
-+ free(ctx); \
-+ ctx = NULL; \
-+ } while (0)
- #else /* USE_OPENSSL */
- #include <openssl/ssl.h>
- #include <openssl/sha.h>
- #include <openssl/hmac.h>
- #include <openssl/rc4.h>
--#define HMAC_setup(ctx, key, len) HMAC_CTX_init(&ctx); HMAC_Init_ex(&ctx, (unsigned char *)key, len, EVP_sha256(), 0)
--#define HMAC_crunch(ctx, buf, len) HMAC_Update(&ctx, (unsigned char *)buf, len)
--#define HMAC_finish(ctx, dig, dlen) HMAC_Final(&ctx, (unsigned char *)dig, &dlen);
--#define HMAC_close(ctx) HMAC_CTX_cleanup(&ctx)
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
-+#define HMAC_setup(ctx, key, len) do { \
-+ if (ctx == NULL) \
-+ ctx = calloc(1, sizeof(*ctx)); \
-+ HMAC_CTX_init(ctx); \
-+ HMAC_Init_ex(ctx, (unsigned char *)key, len, EVP_sha256(), 0); \
-+ } while (0)
-+#else
-+#define HMAC_setup(ctx, key, len) do { \
-+ if (ctx == NULL) \
-+ ctx = HMAC_CTX_new(); \
-+ HMAC_Init_ex(ctx, (unsigned char *)key, len, EVP_sha256(), 0); \
-+ } while (0);
- #endif
-+#define HMAC_crunch(ctx, buf, len) HMAC_Update(ctx, (unsigned char *)buf, len)
-+#define HMAC_finish(ctx, dig, dlen) HMAC_Final(ctx, (unsigned char *)dig, &dlen);
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
-+#define HMAC_close(ctx) do { \
-+ HMAC_CTX_cleanup(ctx); \
-+ free(ctx); \
-+ ctx = NULL; \
-+ } while (0)
-+#else
-+#define HMAC_close(ctx) do { \
-+ HMAC_CTX_reset(ctx); \
-+ HMAC_CTX_free(ctx); \
-+ ctx = NULL; \
-+ } while (0)
-+#endif
-+#endif
-
- extern void RTMP_TLS_Init();
- extern TLS_CTX RTMP_TLS_ctx;
-@@ -298,7 +337,7 @@ struct info
- struct info
- {
- z_stream *zs;
-- HMAC_CTX ctx;
-+ HMAC_CTX *ctx;
- int first;
- int zlib;
- int size;
diff --git a/multimedia/librtmp/files/patch-librtmp-librtmp.pc.in b/multimedia/librtmp/files/patch-librtmp-librtmp.pc.in
deleted file mode 100644
index 44b0d1da91cd..000000000000
--- a/multimedia/librtmp/files/patch-librtmp-librtmp.pc.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- librtmp/librtmp.pc.in.orig 2016-02-29 01:15:13 UTC
-+++ librtmp/librtmp.pc.in
-@@ -8,6 +8,6 @@ Description: RTMP implementation
- Version: @VERSION@
- Requires: @CRYPTO_REQ@
- URL: http://rtmpdump.mplayerhq.hu
--Libs: -L${libdir} -lrtmp -lz @PUBLIC_LIBS@
-+Libs: -L${libdir} -L@OPENSSLLIB@ -lrtmp -lz @PUBLIC_LIBS@
- Libs.private: @PRIVATE_LIBS@
--Cflags: -I${incdir}
-+Cflags: -I${incdir} -I@OPENSSLINC@