aboutsummaryrefslogtreecommitdiff
path: root/multimedia/ogmrip/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/ogmrip/Makefile')
-rw-r--r--multimedia/ogmrip/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/multimedia/ogmrip/Makefile b/multimedia/ogmrip/Makefile
index 4b442d93c12f..14ed9ffaa325 100644
--- a/multimedia/ogmrip/Makefile
+++ b/multimedia/ogmrip/Makefile
@@ -6,14 +6,16 @@
#
PORTNAME= ogmrip
-PORTVERSION= 0.13.6
-PORTREVISION= 1
+PORTVERSION= 0.13.7
CATEGORIES= multimedia
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:R}/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Application and libraries for encoding DVDs into DivX/OGM files
+LICENSE= GPLv2 LGPL21
+LICENSE_COMB= multi
+
BUILD_DEPENDS= mencoder:${PORTSDIR}/multimedia/mencoder \
mplayer:${PORTSDIR}/multimedia/mplayer \
gsed:${PORTSDIR}/textproc/gsed
@@ -41,12 +43,13 @@ USE_GETTEXT= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
-
-MAN1= dvdcpy.1 avibox.1
+MAKE_JOBS_SAFE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+MAN1= dvdcpy.1 avibox.1
+
.include <bsd.port.pre.mk>
.if defined(WITHOUT_GUI)
@@ -131,7 +134,8 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} -e '/local/s|^CFLAGS=|#CFLAGS=|g ; \
/local/s|^CPPFLAGS=|#CPPFLAGS=|g ; \
- /local/s|^LDFLAGS=|#LDFLAGS=|g' ${WRKSRC}/configure
+ /local/s|^LDFLAGS=|#LDFLAGS=|g ; \
+ s|libpng zlib|libpng|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|^SUBDIRS|#SUBDIRS|g' ${WRKSRC}/docs/Makefile.in
@${REINPLACE_CMD} -e \
'/PROGRAM/s|MP4Box|mp4box|g' ${WRKSRC}/libogmrip/ogmrip-mp4.c