aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/dragon/Makefile5
-rw-r--r--multimedia/kamoso/Makefile12
-rw-r--r--multimedia/kdemultimedia-ffmpegthumbs/Makefile3
3 files changed, 12 insertions, 8 deletions
diff --git a/multimedia/dragon/Makefile b/multimedia/dragon/Makefile
index 2e6bc585f233..0dbc71ddb3bb 100644
--- a/multimedia/dragon/Makefile
+++ b/multimedia/dragon/Makefile
@@ -2,6 +2,7 @@
PORTNAME= dragon
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= multimedia kde kde-applications
PKGNAMESUFFIX= -player
@@ -10,12 +11,12 @@ COMMENT= KDE multimedia player with a focus on simplicity
LICENSE= GPLv2
-USES= cmake compiler:c++11-lang gettext kde:5 qt:5 tar:xz
+USES= cmake compiler:c++11-lang desktop-file-utils gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs completion config configwidgets coreaddons crash \
dbusaddons doctools ecm kio service sonnet textwidgets i18n \
iconthemes jobwidgets notifications parts solid widgetsaddons \
windowsystem xmlgui
-USE_QT= core dbus gui network phonon4 widgets xml \
+USE_QT= concurrent core dbus gui network phonon4 widgets xml \
buildtools_build qmake_build
OPTIONS_DEFINE= DOCS
diff --git a/multimedia/kamoso/Makefile b/multimedia/kamoso/Makefile
index 5a491ae6e981..7bb39fc8b330 100644
--- a/multimedia/kamoso/Makefile
+++ b/multimedia/kamoso/Makefile
@@ -2,6 +2,7 @@
PORTNAME= kamoso
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= multimedia kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -9,14 +10,15 @@ COMMENT= Application to take pictures and videos out of your webcam
LICENSE= GPLv2
-USES= cmake compiler:c++11-lang gettext kde:5 pkgconfig qt:5 tar:xz
+USES= cmake compiler:c++11-lang gettext gl kde:5 pkgconfig qt:5 tar:xz
+USE_GL= gl
USE_GNOME= glib20
USE_GSTREAMER1= yes
USE_KDE= auth bookmarks codecs completion config configwidgets \
- coreaddons ecm i18n itemviews jobwidgets kio kirigami2 purpose \
- service solid widgetsaddons xmlgui
-USE_QT= core dbus declarative graphicaleffects gui network quickcontrols \
- widgets xml \
+ coreaddons ecm i18n itemviews jobwidgets kio kirigami2 \
+ notifications purpose service solid widgetsaddons xmlgui
+USE_QT= concurrent core dbus declarative graphicaleffects gui network \
+ quickcontrols widgets xml \
buildtools_build qmake_build
OPTIONS_DEFINE= DOCS
diff --git a/multimedia/kdemultimedia-ffmpegthumbs/Makefile b/multimedia/kdemultimedia-ffmpegthumbs/Makefile
index 09b6ef733399..1f6dc6a7e467 100644
--- a/multimedia/kdemultimedia-ffmpegthumbs/Makefile
+++ b/multimedia/kdemultimedia-ffmpegthumbs/Makefile
@@ -2,6 +2,7 @@
PORTNAME= ffmpegthumbs
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= multimedia kde kde-applications
PKGNAMEPREFIX= kdemultimedia-
@@ -14,7 +15,7 @@ LIB_DEPENDS= libswscale.so:multimedia/ffmpeg
USES= cmake compiler:c++11-lang kde:5 pkgconfig qt:5 tar:xz
USE_KDE= completion config coreaddons i18n jobwidgets kio service widgetsaddons
-USE_QT= core dbus gui network widgets xml \
+USE_QT= concurrent core dbus gui network widgets xml \
buildtools_build qmake_build
OPTIONS_DEFINE= DOCS