aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/bcmatroska2/Makefile2
-rw-r--r--multimedia/dav1d/Makefile2
-rw-r--r--multimedia/gstreamer1-plugins-rust/Makefile2
-rw-r--r--multimedia/gstreamer1-plugins-svt-av1/Makefile2
-rw-r--r--multimedia/helvum/Makefile2
-rw-r--r--multimedia/lebiniou-data/Makefile2
-rw-r--r--multimedia/lebiniou/Makefile2
-rw-r--r--multimedia/libdv/Makefile2
-rw-r--r--multimedia/libndi/Makefile2
-rw-r--r--multimedia/librist/Makefile2
-rw-r--r--multimedia/libvdpau/Makefile2
-rw-r--r--multimedia/libvlcpp/Makefile2
-rw-r--r--multimedia/msopenh264/Makefile2
-rw-r--r--multimedia/mswebrtc/Makefile2
-rw-r--r--multimedia/py-metadata-cleaner/Makefile2
-rw-r--r--multimedia/qpwgraph/Makefile2
-rw-r--r--multimedia/svt-av1/Makefile2
-rw-r--r--multimedia/vdpauinfo/Makefile2
-rw-r--r--multimedia/video-trimmer/Makefile2
-rw-r--r--multimedia/x264/Makefile4
20 files changed, 21 insertions, 21 deletions
diff --git a/multimedia/bcmatroska2/Makefile b/multimedia/bcmatroska2/Makefile
index 0429401f87ec..1d81944b033a 100644
--- a/multimedia/bcmatroska2/Makefile
+++ b/multimedia/bcmatroska2/Makefile
@@ -14,7 +14,7 @@ USES= cmake compiler:c++17-lang
USE_GITLAB= yes
GL_SITE= https://gitlab.linphone.org/BC
GL_ACCOUNT= public
-GL_COMMIT= 4d125bf2788915325c5ab93b9a97835f96d566d3
+GL_TAGNAME= 4d125bf2788915325c5ab93b9a97835f96d566d3
USE_LDCONFIG= yes
CMAKE_ARGS= -DCMAKE_PREFIX_PATH=${LOCALBASE} \
diff --git a/multimedia/dav1d/Makefile b/multimedia/dav1d/Makefile
index f4ff292abd50..964cc4585003 100644
--- a/multimedia/dav1d/Makefile
+++ b/multimedia/dav1d/Makefile
@@ -19,7 +19,7 @@ USE_GITLAB= yes
USE_LDCONFIG= yes
GL_SITE= https://code.videolan.org
GL_ACCOUNT= videolan
-GL_COMMIT= 8a6f054ef1e0f7886bc6e53e6be97c427154fe85
+GL_TAGNAME= 8a6f054ef1e0f7886bc6e53e6be97c427154fe85
LDFLAGS_i386= -Wl,-z,notext
OPTIONS_DEFINE= SDL TEST XXHASH
diff --git a/multimedia/gstreamer1-plugins-rust/Makefile b/multimedia/gstreamer1-plugins-rust/Makefile
index ca5f101f2444..b5a6bbcc8832 100644
--- a/multimedia/gstreamer1-plugins-rust/Makefile
+++ b/multimedia/gstreamer1-plugins-rust/Makefile
@@ -20,7 +20,7 @@ USE_GSTREAMER= bad gl # webrtc
GL_SITE= https://gitlab.freedesktop.org
GL_ACCOUNT= gstreamer
GL_PROJECT= gst-plugins-rs
-GL_COMMIT= a291a2f0982b2d410aec25e007e16ff83a0d5c54
+GL_TAGNAME= a291a2f0982b2d410aec25e007e16ff83a0d5c54
SHEBANG_FILES= dependencies.py
MESON_ARGS= -Ddoc=disabled
MAKE_ENV= ${CARGO_ENV}
diff --git a/multimedia/gstreamer1-plugins-svt-av1/Makefile b/multimedia/gstreamer1-plugins-svt-av1/Makefile
index cb0332d39243..bee0a654ace7 100644
--- a/multimedia/gstreamer1-plugins-svt-av1/Makefile
+++ b/multimedia/gstreamer1-plugins-svt-av1/Makefile
@@ -18,7 +18,7 @@ USE_GITLAB= yes
USE_GNOME= glib20
GL_ACCOUNT= AOMediaCodec
GL_PROJECT= SVT-AV1
-GL_COMMIT= 08c18ba0768ed3dbbff0903adc326fb3a7549bd9
+GL_TAGNAME= 08c18ba0768ed3dbbff0903adc326fb3a7549bd9
WRKSRC_SUBDIR= gstreamer-plugin
PLIST_FILES= lib/gstreamer-1.0/libgstsvtav1enc.so
diff --git a/multimedia/helvum/Makefile b/multimedia/helvum/Makefile
index 5ed9173de3b6..c70680b89eef 100644
--- a/multimedia/helvum/Makefile
+++ b/multimedia/helvum/Makefile
@@ -18,7 +18,7 @@ USE_GITLAB= yes
USE_GNOME= cairo gtk40
GL_SITE= https://gitlab.freedesktop.org
GL_ACCOUNT= ryuukyu
-GL_COMMIT= 69257ffa09e9ac844d22d85e288b97ac98b37665
+GL_TAGNAME= 69257ffa09e9ac844d22d85e288b97ac98b37665
MAKE_ENV= ${CARGO_ENV}
PLIST_FILES= bin/${PORTNAME}
diff --git a/multimedia/lebiniou-data/Makefile b/multimedia/lebiniou-data/Makefile
index aacdfe8b4764..5ec936215157 100644
--- a/multimedia/lebiniou-data/Makefile
+++ b/multimedia/lebiniou-data/Makefile
@@ -13,7 +13,7 @@ USES= autoreconf
USE_GITLAB= YES
GL_ACCOUNT= lebiniou
-GL_COMMIT= 18949ea967b3616d251ea7eeac7f2409991a9030
+GL_TAGNAME= 18949ea967b3616d251ea7eeac7f2409991a9030
GNU_CONFIGURE= YES
diff --git a/multimedia/lebiniou/Makefile b/multimedia/lebiniou/Makefile
index 47710aed351d..3fd2cdffbcb5 100644
--- a/multimedia/lebiniou/Makefile
+++ b/multimedia/lebiniou/Makefile
@@ -36,7 +36,7 @@ USE_SDL= sdl2
USE_LDCONFIG= YES
USE_GITLAB= YES
GL_ACCOUNT= lebiniou
-GL_COMMIT= 2049ce3d9ee5f860fb6a5d516c4af797f4669b58
+GL_TAGNAME= 2049ce3d9ee5f860fb6a5d516c4af797f4669b58
GNU_CONFIGURE= YES
diff --git a/multimedia/libdv/Makefile b/multimedia/libdv/Makefile
index 674d028631bb..8bb8f61f138e 100644
--- a/multimedia/libdv/Makefile
+++ b/multimedia/libdv/Makefile
@@ -18,7 +18,7 @@ USE_GITLAB= yes
GL_SITE= https://gitlab.freedesktop.org/gstreamer
GL_ACCOUNT= meson-ports
GL_PROJECT= libdv
-GL_COMMIT= 24218c36bed3b0a3bd5a57d5790ac12ade44e88d
+GL_TAGNAME= 24218c36bed3b0a3bd5a57d5790ac12ade44e88d
USE_LDCONFIG= yes
diff --git a/multimedia/libndi/Makefile b/multimedia/libndi/Makefile
index 6da7c81e467f..fcae1e68b468 100644
--- a/multimedia/libndi/Makefile
+++ b/multimedia/libndi/Makefile
@@ -20,7 +20,7 @@ USE_LDCONFIG= yes
USE_GITLAB= yes
GL_SITE= https://code.videolan.org
GL_ACCOUNT= jbk
-GL_COMMIT= c14b40caafb26a02249f062e7f907ceaa53c1b74
+GL_TAGNAME= c14b40caafb26a02249f062e7f907ceaa53c1b74
PLIST_FILES= bin/ndi \
include/libndi.h \
diff --git a/multimedia/librist/Makefile b/multimedia/librist/Makefile
index 9291e0fcb34a..11f03186e4e2 100644
--- a/multimedia/librist/Makefile
+++ b/multimedia/librist/Makefile
@@ -18,7 +18,7 @@ USE_LDCONFIG= yes
GL_SITE= https://code.videolan.org
GL_ACCOUNT= rist
-GL_COMMIT= 00d1d3e33fb654d4744ce91fa838b413a4408494
+GL_TAGNAME= 00d1d3e33fb654d4744ce91fa838b413a4408494
MESON_ARGS= -Dtest=false
diff --git a/multimedia/libvdpau/Makefile b/multimedia/libvdpau/Makefile
index 936d435833e4..75dcd6cbb254 100644
--- a/multimedia/libvdpau/Makefile
+++ b/multimedia/libvdpau/Makefile
@@ -15,7 +15,7 @@ USE_XORG= x11 xext xorgproto
USE_LDCONFIG= yes
GL_SITE= https://gitlab.freedesktop.org
GL_ACCOUNT= vdpau
-GL_COMMIT= 79f1506a3307d3275b0fdfb2e110c173f68e6f78
+GL_TAGNAME= 79f1506a3307d3275b0fdfb2e110c173f68e6f78
MESON_ARGS= -Ddocumentation=false
post-patch: .SILENT
diff --git a/multimedia/libvlcpp/Makefile b/multimedia/libvlcpp/Makefile
index 783ba086cb96..fc89e2836dd9 100644
--- a/multimedia/libvlcpp/Makefile
+++ b/multimedia/libvlcpp/Makefile
@@ -18,7 +18,7 @@ USE_GITLAB= yes
GL_SITE= https://code.videolan.org
GL_ACCOUNT= videolan
-GL_COMMIT= 17e622c6a23f685a60451e9611d50e361cee2278
+GL_TAGNAME= 17e622c6a23f685a60451e9611d50e361cee2278
GNU_CONFIGURE= yes
diff --git a/multimedia/msopenh264/Makefile b/multimedia/msopenh264/Makefile
index 1fd1450fc071..6a293d21b116 100644
--- a/multimedia/msopenh264/Makefile
+++ b/multimedia/msopenh264/Makefile
@@ -19,7 +19,7 @@ USES= cmake
USE_GITLAB= yes
GL_SITE= https://gitlab.linphone.org/BC
GL_ACCOUNT= public
-GL_COMMIT= 5c7a9522478f5eedc9a3e1600fdd705da1e00d23
+GL_TAGNAME= 5c7a9522478f5eedc9a3e1600fdd705da1e00d23
CMAKE_ARGS= -DENABLE_STATIC=NO
PLIST_FILES= lib/mediastreamer/plugins/libmsopenh264.so
diff --git a/multimedia/mswebrtc/Makefile b/multimedia/mswebrtc/Makefile
index 812465f8298d..201dec7792c8 100644
--- a/multimedia/mswebrtc/Makefile
+++ b/multimedia/mswebrtc/Makefile
@@ -22,7 +22,7 @@ USE_GITLAB= yes
GL_SITE= https://gitlab.linphone.org/BC
GL_ACCOUNT= public public/external:webrtc
GL_PROJECT= webrtc:webrtc
-GL_COMMIT= 80b8e33b11516870b887b80279b9da4de8b26ebe \
+GL_TAGNAME= 80b8e33b11516870b887b80279b9da4de8b26ebe \
583acd27665cfadef8ab03eb85a768d308bd29dd:webrtc
GL_SUBDIR= webrtc:webrtc
diff --git a/multimedia/py-metadata-cleaner/Makefile b/multimedia/py-metadata-cleaner/Makefile
index 753534c87b9f..7f4d5bb78c74 100644
--- a/multimedia/py-metadata-cleaner/Makefile
+++ b/multimedia/py-metadata-cleaner/Makefile
@@ -29,6 +29,6 @@ SHEBANG_GLOB= *.py *.py.in
BINARY_ALIAS= python3=${PYTHON_VERSION}
NO_ARCH= yes
GL_ACCOUNT= rmnvgr
-GL_COMMIT= 62a400a96099d947502611a1b9bc67f7f48a675a
+GL_TAGNAME= 62a400a96099d947502611a1b9bc67f7f48a675a
.include <bsd.port.mk>
diff --git a/multimedia/qpwgraph/Makefile b/multimedia/qpwgraph/Makefile
index f535579a9853..2f14d3634bdd 100644
--- a/multimedia/qpwgraph/Makefile
+++ b/multimedia/qpwgraph/Makefile
@@ -18,7 +18,7 @@ USE_QT= core gui network widgets buildtools:build qmake:build
USE_GITLAB= yes
GL_SITE= https://gitlab.freedesktop.org
GL_ACCOUNT= rncbc
-GL_COMMIT= 71edb283e7b5d4429d5ef9951de6b740afb07790
+GL_TAGNAME= 71edb283e7b5d4429d5ef9951de6b740afb07790
PLIST_FILES= bin/qpwgraph
diff --git a/multimedia/svt-av1/Makefile b/multimedia/svt-av1/Makefile
index b819ba4060bb..73b81757f1e2 100644
--- a/multimedia/svt-av1/Makefile
+++ b/multimedia/svt-av1/Makefile
@@ -21,7 +21,7 @@ USE_GITLAB= yes
USE_LDCONFIG= yes
GL_ACCOUNT= AOMediaCodec
GL_PROJECT= SVT-AV1
-GL_COMMIT= 08c18ba0768ed3dbbff0903adc326fb3a7549bd9
+GL_TAGNAME= 08c18ba0768ed3dbbff0903adc326fb3a7549bd9
CMAKE_ON= ENABLE_NASM
CMAKE_OFF= NATIVE
diff --git a/multimedia/vdpauinfo/Makefile b/multimedia/vdpauinfo/Makefile
index 9e1a1332460a..e2334b51d588 100644
--- a/multimedia/vdpauinfo/Makefile
+++ b/multimedia/vdpauinfo/Makefile
@@ -16,7 +16,7 @@ USE_XORG= x11
USE_GITLAB= yes
GL_SITE= https://gitlab.freedesktop.org
GL_ACCOUNT= vdpau
-GL_COMMIT= d3c5bd63bf8878d59b22d618d2bb5116db392d28
+GL_TAGNAME= d3c5bd63bf8878d59b22d618d2bb5116db392d28
GNU_CONFIGURE= yes
PLIST_FILES= bin/vdpauinfo
diff --git a/multimedia/video-trimmer/Makefile b/multimedia/video-trimmer/Makefile
index dbf803dd1e1c..19fbedb2fa49 100644
--- a/multimedia/video-trimmer/Makefile
+++ b/multimedia/video-trimmer/Makefile
@@ -20,7 +20,7 @@ USE_GNOME= gtk40 libadwaita
USE_GSTREAMER= good libav
GL_SITE= https://gitlab.gnome.org
GL_ACCOUNT= YaLTeR
-GL_COMMIT= 0232139f9b68be808c9091abf6d3189fdb2ace36
+GL_TAGNAME= 0232139f9b68be808c9091abf6d3189fdb2ace36
MAKE_ENV= ${CARGO_ENV}
CARGO_BUILD= no
CARGO_INSTALL= no
diff --git a/multimedia/x264/Makefile b/multimedia/x264/Makefile
index 173ca9366c60..731fa39e5561 100644
--- a/multimedia/x264/Makefile
+++ b/multimedia/x264/Makefile
@@ -34,7 +34,7 @@ LIB_DEPENDS?= libx264.so:multimedia/libx264
X264_BUILD= 164
X264_REV= 3095
-X264_GITVER= ${GL_COMMIT:C/^(.{7}).*/\1/}
+X264_GITVER= ${GL_TAGNAME:C/^(.{7}).*/\1/}
USES?= pkgconfig
USES+= compiler:c11 gmake localbase shebangfix
@@ -42,7 +42,7 @@ USE_GITLAB= yes
USE_LDCONFIG= yes
GL_SITE= https://code.videolan.org
GL_ACCOUNT= videolan
-GL_COMMIT= baee400fa9ced6f5481a728138fed6e867b0ff7f
+GL_TAGNAME= baee400fa9ced6f5481a728138fed6e867b0ff7f
HAS_CONFIGURE= yes
SHEBANG_FILES= configure
PLIST_FILES?= bin/x264