aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/x265/Makefile9
-rw-r--r--multimedia/x265/distinfo6
-rw-r--r--multimedia/x265/files/patch-source_abrEncApp.cpp9
3 files changed, 8 insertions, 16 deletions
diff --git a/multimedia/x265/Makefile b/multimedia/x265/Makefile
index 1ad0be68be0e..1dc91973982a 100644
--- a/multimedia/x265/Makefile
+++ b/multimedia/x265/Makefile
@@ -4,8 +4,7 @@
PORTNAME= x265
PORTVERSION= 3.4
CATEGORIES= multimedia
-MASTER_SITES= https://bitbucket.org/multicoreware/x265/downloads/
-DISTNAME= ${PORTNAME}_${PORTVERSION}
+MASTER_SITES= https://bitbucket.org/multicoreware/x265_git/get/${BB_TAG}.tar.gz?meow=/
MAINTAINER= mi@aldan.algebra.com
COMMENT= H.265/High Efficiency Video Coding (HEVC) format
@@ -15,6 +14,8 @@ LICENSE_FILE= ${WRKSRC:H}/COPYING
USES= cmake compiler:c++14-lang pathfix dos2unix
+BB_TAG= 25b2c07035ff # Top of the Release_3.4 branch at this time
+
OPTIONS_DEFINE= DEBUG OPTIMIZED_FLAGS VMAF
OPTIONS_DEFAULT= OPTIMIZED_FLAGS HI8P HI10P HI12P
OPTIONS_DEFINE_aarch64= ASM
@@ -50,9 +51,9 @@ VMAF_DESC= Per frame and aggregate VMAF score
USE_LDCONFIG= yes
CMAKE_ARGS= -DENABLE_TESTS=on -DENABLE_HDR10_PLUS:BOOL=true
LDFLAGS_i386= -Wl,-znotext
-EXTRACT_AFTER_ARGS+= --exclude compat
+EXTRACT_AFTER_ARGS+= --exclude compat --strip-components=1
PATCH_WRKSRC= ${WRKSRC:H}
-WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}/source
+WRKSRC= ${WRKDIR}/source
.include <bsd.port.options.mk>
diff --git a/multimedia/x265/distinfo b/multimedia/x265/distinfo
index e39956095aa8..cec36bc8e5d6 100644
--- a/multimedia/x265/distinfo
+++ b/multimedia/x265/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1591425294
-SHA256 (x265_3.4.tar.gz) = c2047f23a6b729e5c70280d23223cb61b57bfe4ad4e8f1471eeee2a61d148672
-SIZE (x265_3.4.tar.gz) = 1469365
+TIMESTAMP = 1600662771
+SHA256 (x265-3.4.tar.gz) = 01f17d94689ef79807fa2b4bd7f5f58bb18416e72a135c7f56c30162a980cfb8
+SIZE (x265-3.4.tar.gz) = 1532396
diff --git a/multimedia/x265/files/patch-source_abrEncApp.cpp b/multimedia/x265/files/patch-source_abrEncApp.cpp
deleted file mode 100644
index c9a38bdcfabe..000000000000
--- a/multimedia/x265/files/patch-source_abrEncApp.cpp
+++ /dev/null
@@ -1,9 +0,0 @@
---- source/abrEncApp.cpp 2020-05-29 13:39:35.000000000 -0400
-+++ source/abrEncApp.cpp 2020-07-19 17:37:32.365958000 -0400
-@@ -815,5 +815,5 @@
- if (m_param->csvfn && !b_ctrl_c)
- #if ENABLE_LIBVMAF
-- api->vmaf_encoder_log(m_encoder, m_cliopt.argCount, m_cliopt.argString, m_cliopt.param, vmafdata);
-+ api->vmaf_encoder_log(m_encoder, m_cliopt.argCnt, m_cliopt.argString, m_cliopt.param, vmafdata);
- #else
- api->encoder_log(m_encoder, m_cliopt.argCnt, m_cliopt.argString);