aboutsummaryrefslogtreecommitdiff
path: root/net-im/pidgin/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/pidgin/Makefile')
-rw-r--r--net-im/pidgin/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/net-im/pidgin/Makefile b/net-im/pidgin/Makefile
index 4ff40b3878b9..cc23b69d270e 100644
--- a/net-im/pidgin/Makefile
+++ b/net-im/pidgin/Makefile
@@ -13,7 +13,7 @@ MAINTAINER= marcus@FreeBSD.org
COMMENT= Pidgin multi-protocol messaging client (GTK+ UI)
LIB_DEPENDS= startup-notification-1.0:${PORTSDIR}/x11/startup-notification \
- purple.6:${PORTSDIR}/net-im/libpurple
+ purple.7:${PORTSDIR}/net-im/libpurple
MASTERDIR= ${.CURDIR}/../libpurple
BUILD_WRKSRC= ${WRKSRC}/pidgin
@@ -31,18 +31,23 @@ USE_XORG= xscrnsaver sm
WANT_GNOME= yes
CONFIGURE_ARGS= --disable-consoleui \
--disable-nm \
+ --enable-screensaver \
--with-dynamic_prpls=${PRPL_MODULES:S/,$//}
MAN1= pidgin.1
post-build:
+.if !defined(WITHOUT_NLS)
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
Makefile ${MAKE_ARGS} pidgin.desktop
+.endif
post-install:
+.if !defined(WITHOUT_NLS)
${MKDIR} ${PREFIX}/share/applications
${INSTALL_DATA} ${WRKSRC}/pidgin.desktop \
${PREFIX}/share/applications/pidgin.desktop
+.endif
${INSTALL_MAN} ${WRKSRC}/doc/pidgin.1 ${MAN1PREFIX}/man/man1
.include "${MASTERDIR}/Makefile"