aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
Diffstat (limited to 'net-im')
-rw-r--r--net-im/mtxclient/Makefile9
-rw-r--r--net-im/mtxclient/distinfo6
-rw-r--r--net-im/mtxclient/pkg-plist15
-rw-r--r--net-im/nheko/Makefile18
-rw-r--r--net-im/nheko/distinfo6
5 files changed, 34 insertions, 20 deletions
diff --git a/net-im/mtxclient/Makefile b/net-im/mtxclient/Makefile
index 629581e88f0b..b63ef0bcb23a 100644
--- a/net-im/mtxclient/Makefile
+++ b/net-im/mtxclient/Makefile
@@ -2,8 +2,7 @@
PORTNAME= mtxclient
DISTVERSIONPREFIX= v
-DISTVERSION= 0.3.1
-PORTREVISION= 3
+DISTVERSION= 0.4.0
CATEGORIES= net-im
MAINTAINER= adridg@FreeBSD.org
@@ -12,8 +11,7 @@ COMMENT= Client API library for the Matrix protocol
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= nlohmann-json>=3:devel/nlohmann-json \
- googletest>0:devel/googletest
+BUILD_DEPENDS= nlohmann-json>=3:devel/nlohmann-json
LIB_DEPENDS= libsodium.so:security/libsodium \
libboost_date_time.so:devel/boost-libs \
libboost_chrono.so:devel/boost-libs \
@@ -26,8 +24,11 @@ LIB_DEPENDS= libsodium.so:security/libsodium \
USES= cmake compiler:c++17-lang pkgconfig ssl \
tar:xz
+CMAKE_OFF= BUILD_LIB_TESTS
USE_GITHUB= yes
GH_ACCOUNT= Nheko-Reborn
+PLIST_SUB= SOVER=${DISTVERSION}
+
.include <bsd.port.mk>
diff --git a/net-im/mtxclient/distinfo b/net-im/mtxclient/distinfo
index e86695abec68..df03da64c1a9 100644
--- a/net-im/mtxclient/distinfo
+++ b/net-im/mtxclient/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1592215303
-SHA256 (Nheko-Reborn-mtxclient-v0.3.1_GH0.tar.gz) = e4899cc4ce87397de2aef865e94ea2cdb8d9cb86253727e7d90532b925ecc770
-SIZE (Nheko-Reborn-mtxclient-v0.3.1_GH0.tar.gz) = 511985
+TIMESTAMP = 1611263677
+SHA256 (Nheko-Reborn-mtxclient-v0.4.0_GH0.tar.gz) = c02c0109c9bbfd15fc016c6770dec23809ba6ddb3c4f89a291e462baa3360863
+SIZE (Nheko-Reborn-mtxclient-v0.4.0_GH0.tar.gz) = 571434
diff --git a/net-im/mtxclient/pkg-plist b/net-im/mtxclient/pkg-plist
index f85f66d9ce74..e9d02a0309f1 100644
--- a/net-im/mtxclient/pkg-plist
+++ b/net-im/mtxclient/pkg-plist
@@ -2,6 +2,7 @@ include/mtx.hpp
include/mtx/common.hpp
include/mtx/errors.hpp
include/mtx/events.hpp
+include/mtx/events/account_data/fully_read.hpp
include/mtx/events/aliases.hpp
include/mtx/events/avatar.hpp
include/mtx/events/canonical_alias.hpp
@@ -10,6 +11,9 @@ include/mtx/events/common.hpp
include/mtx/events/create.hpp
include/mtx/events/encrypted.hpp
include/mtx/events/encryption.hpp
+include/mtx/events/ephemeral/receipt.hpp
+include/mtx/events/ephemeral/typing.hpp
+include/mtx/events/event_type.hpp
include/mtx/events/guest_access.hpp
include/mtx/events/history_visibility.hpp
include/mtx/events/join_rules.hpp
@@ -22,6 +26,7 @@ include/mtx/events/messages/notice.hpp
include/mtx/events/messages/text.hpp
include/mtx/events/messages/video.hpp
include/mtx/events/name.hpp
+include/mtx/events/nheko_extensions/hidden_events.hpp
include/mtx/events/pinned_events.hpp
include/mtx/events/power_levels.hpp
include/mtx/events/presence.hpp
@@ -30,7 +35,11 @@ include/mtx/events/redaction.hpp
include/mtx/events/tag.hpp
include/mtx/events/tombstone.hpp
include/mtx/events/topic.hpp
+include/mtx/events/unknown.hpp
+include/mtx/events/voip.hpp
+include/mtx/events_impl.hpp
include/mtx/identifiers.hpp
+include/mtx/lightweight_error.hpp
include/mtx/log.hpp
include/mtx/pushrules.hpp
include/mtx/requests.hpp
@@ -45,16 +54,20 @@ include/mtx/responses/media.hpp
include/mtx/responses/messages.hpp
include/mtx/responses/notifications.hpp
include/mtx/responses/profile.hpp
+include/mtx/responses/public_rooms.hpp
include/mtx/responses/register.hpp
include/mtx/responses/sync.hpp
+include/mtx/responses/turn_server.hpp
include/mtx/responses/version.hpp
include/mtx/responses/well-known.hpp
+include/mtx/secret_storage.hpp
include/mtx/user_interactive.hpp
include/mtxclient/crypto/client.hpp
include/mtxclient/crypto/objects.hpp
include/mtxclient/crypto/types.hpp
include/mtxclient/crypto/utils.hpp
include/mtxclient/http/client.hpp
+include/mtxclient/http/client_impl.hpp
include/mtxclient/http/errors.hpp
include/mtxclient/http/session.hpp
include/mtxclient/utils.hpp
@@ -63,4 +76,4 @@ lib/cmake/MatrixClient/MatrixClientConfigVersion.cmake
lib/cmake/MatrixClient/MatrixClientTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/MatrixClient/MatrixClientTargets.cmake
lib/libmatrix_client.so
-lib/libmatrix_client.so.0.3.1
+lib/libmatrix_client.so.%%SOVER%%
diff --git a/net-im/nheko/Makefile b/net-im/nheko/Makefile
index f71351937f6a..0b30bad9e2d4 100644
--- a/net-im/nheko/Makefile
+++ b/net-im/nheko/Makefile
@@ -2,8 +2,7 @@
PORTNAME= nheko
DISTVERSIONPREFIX=v
-DISTVERSION= 0.7.2
-PORTREVISION= 3
+DISTVERSION= 0.8.0
CATEGORIES= net-im
MAINTAINER= adridg@FreeBSD.org
@@ -15,18 +14,19 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= nlohmann-json>=3:devel/nlohmann-json
# All those boost-libs are pulled in through mtxclient, which
# links to them but stage-qa still complains.
-LIB_DEPENDS= liblmdb.so:databases/lmdb \
- libfmt.so:devel/libfmt \
- libmatrix_client.so:net-im/mtxclient \
- libsodium.so:security/libsodium \
- libolm.so:security/olm \
- libcmark.so:textproc/cmark \
- libboost_date_time.so:devel/boost-libs \
+LIB_DEPENDS= \
libboost_chrono.so:devel/boost-libs \
+ libboost_date_time.so:devel/boost-libs \
libboost_iostreams.so:devel/boost-libs \
libboost_regex.so:devel/boost-libs \
libboost_system.so:devel/boost-libs \
libboost_thread.so:devel/boost-libs \
+ libcmark.so:textproc/cmark \
+ libfmt.so:devel/libfmt \
+ liblmdb.so:databases/lmdb \
+ libmatrix_client.so:net-im/mtxclient \
+ libolm.so:security/olm \
+ libqt5keychain.so:security/qtkeychain \
libspdlog.so:devel/spdlog
USES= cmake compiler:c++17-lang pkgconfig \
diff --git a/net-im/nheko/distinfo b/net-im/nheko/distinfo
index c12bae269134..4cc4239e6d92 100644
--- a/net-im/nheko/distinfo
+++ b/net-im/nheko/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1592215601
-SHA256 (Nheko-Reborn-nheko-v0.7.2_GH0.tar.gz) = 412908fcec0e66a0557db5359556b65e85dd22b8644a6a2ed569a90dea4bde3c
-SIZE (Nheko-Reborn-nheko-v0.7.2_GH0.tar.gz) = 899562
+TIMESTAMP = 1611264445
+SHA256 (Nheko-Reborn-nheko-v0.8.0_GH0.tar.gz) = 07f58142cabd76809fb5d8c3f97488b9bd5be7858aaee4826cd6a35d966f5c98
+SIZE (Nheko-Reborn-nheko-v0.8.0_GH0.tar.gz) = 1150754
SHA256 (drycpp-lmdbxx-0b43ca87d8cfabba392dfe884eb1edb83874de02_GH0.tar.gz) = 93721132bbf5045d38ad62de2997655e9984c48ea5c9886746d42128f4b26fbd
SIZE (drycpp-lmdbxx-0b43ca87d8cfabba392dfe884eb1edb83874de02_GH0.tar.gz) = 47524
SHA256 (mobius3-tweeny-6a5033372fe53c4c731c66c8a2d56261746cd85c_GH0.tar.gz) = c9fcabcdbeb89e4236bbb773ddacf6293ca2a8618f2b1a67e689e3edb704ecd3