aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
Diffstat (limited to 'net-im')
-rw-r--r--net-im/libjingle/Makefile2
-rw-r--r--net-im/libjingle/files/patch-talk__xmpp__saslplainmechanism.h11
2 files changed, 12 insertions, 1 deletions
diff --git a/net-im/libjingle/Makefile b/net-im/libjingle/Makefile
index b8d56b442f85..b7be6bb4fe20 100644
--- a/net-im/libjingle/Makefile
+++ b/net-im/libjingle/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libjingle
PORTVERSION= 0.3.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net-im
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/net-im/libjingle/files/patch-talk__xmpp__saslplainmechanism.h b/net-im/libjingle/files/patch-talk__xmpp__saslplainmechanism.h
new file mode 100644
index 000000000000..b6892aa4e16c
--- /dev/null
+++ b/net-im/libjingle/files/patch-talk__xmpp__saslplainmechanism.h
@@ -0,0 +1,11 @@
+--- talk/xmpp/saslplainmechanism.h.orig Wed May 10 07:43:35 2006
++++ talk/xmpp/saslplainmechanism.h Wed May 10 07:44:01 2006
+@@ -48,7 +48,7 @@
+
+ FormatXmppPassword credential;
+ credential.Append("\0", 1);
+- credential.Append(user_jid_.Str());
++ credential.Append(user_jid_.node());
+ credential.Append("\0", 1);
+ credential.Append(&password_);
+ el->AddText(Base64EncodeFromArray(credential.GetData(), credential.GetLength()));