aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/bandwidthd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/bandwidthd/Makefile')
-rw-r--r--net-mgmt/bandwidthd/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/net-mgmt/bandwidthd/Makefile b/net-mgmt/bandwidthd/Makefile
index 680f88b293cd..7843a174a7a7 100644
--- a/net-mgmt/bandwidthd/Makefile
+++ b/net-mgmt/bandwidthd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= bandwidthd
PORTVERSION= 2.0.1
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= net-mgmt
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}%20${PORTVERSION}
@@ -12,8 +12,7 @@ COMMENT= Tracks bandwidth usage by IP address
LICENSE= GPLv2
-LIB_DEPENDS+= libgd.so:${PORTSDIR}/graphics/gd \
- libpng16.so:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libgd.so:${PORTSDIR}/graphics/gd
SUB_FILES= bandwidthd
@@ -21,9 +20,15 @@ USE_CSTD= gnu89
GNU_CONFIGURE= YES
CONFIGURE_ARGS= ac_cv_lib_iconv_libiconv_open=no \
+ ac_cv_lib_m_pow=no \
+ ac_cv_lib_png_png_read_info=no \
ac_cv_lib_pq_PQconnectdb=no
USES= gmake tar:tgz
+post-patch:
+ ${REINPLACE_CMD} -e '/requires.*libpng/,/exit/d' \
+ ${WRKSRC}/configure
+
post-install:
${INSTALL_SCRIPT} ${WRKDIR}/bandwidthd \
${STAGEDIR}${PREFIX}/etc/rc.d