aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/bsnmp-regex/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/bsnmp-regex/Makefile')
-rw-r--r--net-mgmt/bsnmp-regex/Makefile29
1 files changed, 11 insertions, 18 deletions
diff --git a/net-mgmt/bsnmp-regex/Makefile b/net-mgmt/bsnmp-regex/Makefile
index 62ef0283315c..a10e74da945b 100644
--- a/net-mgmt/bsnmp-regex/Makefile
+++ b/net-mgmt/bsnmp-regex/Makefile
@@ -1,6 +1,6 @@
PORTNAME= bsnmp-regex
PORTVERSION= 0.6
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net-mgmt
MASTER_SITES= LOCAL/olivier
@@ -10,33 +10,26 @@ WWW= http://thewalter.net/stef/software/bsnmp-regex/
LICENSE= BSD3CLAUSE
+USES= libtool localbase
+
GNU_CONFIGURE= yes
GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
-CPPFLAGS+= "-I${LOCALBASE}/include"
-INSTALL_TARGET= install-strip
-USES= libtool
-OPTIONS_DEFINE= DEBUG PCRE
-PCRE_DESC= Use PCRE instead of the default regex library
+INSTALL_TARGET= install-strip
PLIST_FILES= bin/sockin lib/snmp_regex.so lib/snmp_regex.so.0 \
lib/snmp_regex.so.0.0.0 lib/snmp_regex.a share/man/man1/sockin.1.gz \
share/man/man5/bsnmp-regex.conf.5.gz \
share/man/man8/bsnmp-regex.8.gz
-.include <bsd.port.options.mk>
+# OPTION PCRE is safe to be removed when devel/pcre is removed
+# CONFIGURE_ARGS+= --disable-pcre
+OPTIONS_DEFINE= DEBUG PCRE
-.if ${PORT_OPTIONS:MDEBUG}
-CONFIGURE_ARGS+=--enable-debug
-.else
-CONFIGURE_ARGS+=--disable-debug
-.endif
+PCRE_DESC= Use PCRE instead of the default regex library
-.if ${PORT_OPTIONS:MPCRE}
-LIB_DEPENDS+= libpcre.so:devel/pcre
-CONFIGURE_ARGS+= --enable-pcre
-.else
-CONFIGURE_ARGS+= --disable-pcre
-.endif
+DEBUG_CONFIGURE_ENABLE=debug
+PCRE_LIB_DEPENDS= libpcre.so:devel/pcre
+PCRE_CONFIGURE_ENABLE=pcre
.include <bsd.port.mk>