aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/ettercap/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/ettercap/Makefile')
-rw-r--r--net-mgmt/ettercap/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/net-mgmt/ettercap/Makefile b/net-mgmt/ettercap/Makefile
index b081c11a9e34..2b0ade53340a 100644
--- a/net-mgmt/ettercap/Makefile
+++ b/net-mgmt/ettercap/Makefile
@@ -32,6 +32,7 @@ CMAKE_ARGS= -DBUNDLED_LIBS=OFF \
CMAKE_VERBOSE= yes
LDFLAGS+= -L${LIBDIR} -L${LOCALBASE}/lib -L${LOCALBASE}/lib/libnet11 ${ICONV_LIB} -lnet -lpcap
MAKE_JOBS_UNSAFE= yes
+USE_LDCONFIG= yes
USES= bison cmake:outsource cpe iconv pkgconfig
DOCS= AUTHORS CHANGELOG README README.BINARIES README.BUGS \
@@ -66,8 +67,6 @@ PLUGINS_BUILD_DEPENDS= curl>=7.26.0:${PORTSDIR}/ftp/curl
PLUGINS_CMAKE_OFF= -DENABLE_PLUGINS=OFF
PLUGINS_CMAKE_ON= -DENABLE_PLUGINS=ON
PLUGINS_LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
-PLUGINS_USE= LDCONFIG=${PREFIX}/lib/ettercap
-PLUGINS_USE_OFF= LDCONFIG=yes
SSL_CMAKE_OFF= -DENABLE_SSL=OFF
SSL_CMAKE_ON= -DENABLE_SSL=ON
SSL_USE= OPENSSL=yes