aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nagios2
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/nagios2')
-rw-r--r--net-mgmt/nagios2/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/net-mgmt/nagios2/Makefile b/net-mgmt/nagios2/Makefile
index ff0dd52082e4..a22f55280c09 100644
--- a/net-mgmt/nagios2/Makefile
+++ b/net-mgmt/nagios2/Makefile
@@ -37,6 +37,21 @@ CONFIGURE_ARGS= --with-command-user=nagios \
--localstatedir=${PREFIX}/var/nagios \
--prefix=${PREFIX}
+.if defined(WITH_MYSQL)
+LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+CONFIGURE_ARGS+=--with-mysql-lib=${LOCALBASE}/lib/mysql \
+ --with-mysql-inc=${LOCALBASE}/include/mysql \
+ --with-mysql-xdata
+.endif
+
+.if defined(WITH_POSTGRES)
+POSTGRESQL_PORT?= databases/postgresql7
+LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
+CONFIGURE_ARGS+=--with-pgsql-lib=${LOCALBASE}/pgsql \
+ --with-pgsql-inc=${LOCALBASE}/pgsql \
+ --with-pgsql-xdata
+.endif
+
INSTALL_TARGET= all install config install-config install-daemoninit install-commandmode
pre-fetch: