aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nagstamon/files/patch-setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/nagstamon/files/patch-setup.py')
-rw-r--r--net-mgmt/nagstamon/files/patch-setup.py12
1 files changed, 12 insertions, 0 deletions
diff --git a/net-mgmt/nagstamon/files/patch-setup.py b/net-mgmt/nagstamon/files/patch-setup.py
new file mode 100644
index 000000000000..485eaf60021c
--- /dev/null
+++ b/net-mgmt/nagstamon/files/patch-setup.py
@@ -0,0 +1,12 @@
+--- setup.py.orig 2021-03-22 15:58:33 UTC
++++ setup.py
+@@ -36,6 +36,9 @@ OS = platform.system()
+ if OS not in ['Windows', 'Darwin']:
+ if OS == 'Linux':
+ DIST, DIST_VERSION, DIST_NAME = get_distro()
++ # platform.dist() returns "('', '', '')" on FreeBSD
++ elif OS == 'FreeBSD':
++ DIST, DIST_VERSION, DIST_NAME = ('', '', '')
+ else:
+ DIST, DIST_VERSION, DIST_NAME = platform.dist()
+ NAME = NAME.lower()