aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/deluge/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/deluge/Makefile')
-rw-r--r--net-p2p/deluge/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/net-p2p/deluge/Makefile b/net-p2p/deluge/Makefile
index 00c4503f5168..49aad9c45621 100644
--- a/net-p2p/deluge/Makefile
+++ b/net-p2p/deluge/Makefile
@@ -29,6 +29,8 @@ USE_PYTHON= yes
USE_GCC= 4.3+
MAKE_ENV= PYTHONPATH="${PYTHONPREFIX_SITELIBDIR}"
+OPTIONS= PSYCO "Enable devel/py-psyco optimization support (i386)" off
+
MAN1= deluge.1 deluged.1
PLIST_SUB= VERSION="${PORTVERSION}" PYTHON_VER="${PYTHON_VER}"
@@ -43,6 +45,18 @@ INSTALLS_ICONS= yes
.include <bsd.port.pre.mk>
+.if ${ARCH} != "i386"
+.undef WITH_PSYCO
+
+WITHOUT_PSYCO= yes
+.endif
+
+.if defined(WITH_PSYCO)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psyco/_psyco.so:${PORTSDIR}/devel/py-psyco
+
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-deluge__main.py
+.endif
+
.if (exists(${LOCALBASE}/lib/libboost_iostreams.so) && \
!exists(${LOCALBASE}/lib/libboost_python.so))
IGNORE= cannot find dependency: The boost exists but not with Python support. Please uninstall boost and install boost-python or reinstall boost with Python support