aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/net-p2p/qbittorrent/Makefile b/net-p2p/qbittorrent/Makefile
index 6351492c1ae3..09d9a2211b5f 100644
--- a/net-p2p/qbittorrent/Makefile
+++ b/net-p2p/qbittorrent/Makefile
@@ -3,7 +3,7 @@
PORTNAME= qbittorrent
DISTVERSION= 4.3.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-p2p
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -47,13 +47,19 @@ PLIST_SUB= USER=${USERS} GROUP=${GROUPS}
OPTIONS_EXCLUDE= DBUS
.endif
-OPTIONS_DEFINE= DBUS DEBUG
+OPTIONS_DEFINE= DBUS PYTHON DEBUG
OPTIONS_DEFAULT= DBUS
DEBUG_CONFIGURE_ENABLE= debug
DBUS_CONFIGURE_ENABLE= qt-dbus
DBUS_USE= qt=dbus
+PYTHON_DESC= Install Python to support some plugin functionality
+PYTHON_USES= python:3.6+,run
+
+post-patch-PYTHON-on:
+ @${REINPLACE_CMD} -e 's|"python3"|"${PYTHON_CMD}"|' ${WRKSRC}/src/base/utils/foreignapps.cpp
+
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/qbittorrent${SUFFIX}
${INSTALL_MAN} ${WRKSRC}/doc/qbittorrent${SUFFIX}.1 \