aboutsummaryrefslogtreecommitdiff
path: root/net/asterisk16/files/patch-res::Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/asterisk16/files/patch-res::Makefile')
-rw-r--r--net/asterisk16/files/patch-res::Makefile50
1 files changed, 26 insertions, 24 deletions
diff --git a/net/asterisk16/files/patch-res::Makefile b/net/asterisk16/files/patch-res::Makefile
index 3e48e84189a2..de5c365db34d 100644
--- a/net/asterisk16/files/patch-res::Makefile
+++ b/net/asterisk16/files/patch-res::Makefile
@@ -1,33 +1,35 @@
---- res/Makefile.orig Tue Aug 9 17:18:55 2005
-+++ res/Makefile Tue Aug 9 17:33:36 2005
-@@ -13,15 +13,18 @@
+
+$FreeBSD$
+
+--- res/Makefile
++++ res/Makefile
+@@ -37,8 +37,8 @@
+ endif
- MODS=res_adsi.so res_features.so res_crypto.so res_musiconhold.so res_indications.so res_monitor.so \
- res_agi.so res_watchdog.so
--MODS+=$(shell if [ -f "/usr/include/odbcinst.h" ]; then echo "res_odbc.so res_config_odbc.so"; fi)
--MODS+=$(shell if [ -f "/usr/local/include/odbcinst.h" ]; then echo "res_odbc.so res_config_odbc.so"; fi)
-+#MODS+=$(shell if [ -f "/usr/include/odbcinst.h" ]; then echo "res_odbc.so res_config_odbc.so"; fi)
-+#MODS+=$(shell if [ -f "/usr/local/include/odbcinst.h" ]; then echo "res_odbc.so res_config_odbc.so"; fi)
- MODS+=$(shell if [ -f "/usr/include/osp/osp.h" ]; then echo "res_osp.so"; fi)
-
- CRYPTO_LIBS=-lssl -lcrypto
+ ifeq ($(findstring BSD,${OSARCH}),BSD)
+- CFLAGS+=-I$(CROSS_COMPILE_TARGET)/usr/local/include
+- SOLINK+=-L$(CROSS_COMPILE_TARGET)/usr/local/lib
++ CFLAGS+=-I$(CROSS_COMPILE_TARGET)$(LOCALBASE)/include
++ SOLINK+=-L$(CROSS_COMPILE_TARGET)$(LOCALBASE)/lib
+ endif
+ ifeq (${OSARCH},CYGWIN)
+@@ -55,9 +55,7 @@
CFLAGS+=
- CFLAGS+=$(shell [ -f /usr/include/linux/zaptel.h ] && echo " -DZAPATA_MOH")
--CFLAGS+=$(shell [ -f /usr/local/include/zaptel.h ] && echo " -DZAPATA_MOH")
-+CFLAGS+=-I$(LOCALBASE)/include
-+ifdef WITH_ZAPTEL
-+CFLAGS+=-DZAPATA_MOH
-+endif
- #
- # Work around buggy RedHat 9.0
+
+ ifndef WITHOUT_ZAPTEL
+-ifneq ($(wildcard $(CROSS_COMPILE_TARGET)/usr/include/linux/zaptel.h)$(wildcard $(CROSS_COMPILE_TARGET)/usr/local/include/zaptel.h),)
+ CFLAGS+=-DZAPATA_MOH
+-endif
+ endif # WITHOUT_ZAPTEL
+
#
-@@ -34,7 +37,7 @@
+@@ -75,7 +73,7 @@
rm -f $(DESTDIR)$(ASTHEADERDIR)/parking.h
rm -f $(DESTDIR)$(MODULES_DIR)/app_agi.so
rm -f $(DESTDIR)$(MODULES_DIR)/res_parking.so
- for x in $(MODS); do $(INSTALL) -m 755 $$x $(DESTDIR)$(MODULES_DIR) ; done
+ for x in $(MODS); do $(BSD_INSTALL_PROGRAM) $$x $(DESTDIR)$(MODULES_DIR) ; done
-
- res_crypto.so: res_crypto.o
- $(CC) $(SOLINK) -o $@ $< $(CRYPTO_LIBS)
+ @if [ x`which mpg123 2>/dev/null | grep -v '^no'` != x ] ; then \
+ if mpg123 --longhelp 2>&1 | grep -q .59r 2>&1 >/dev/null ; then echo ; else \
+ echo "*************************************************************";\