aboutsummaryrefslogtreecommitdiff
path: root/net/gupnp-ui/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/gupnp-ui/Makefile')
-rw-r--r--net/gupnp-ui/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/net/gupnp-ui/Makefile b/net/gupnp-ui/Makefile
new file mode 100644
index 000000000000..c3b782c86eee
--- /dev/null
+++ b/net/gupnp-ui/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: gupnp-ui
+# Date created: 2009-12-26
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gupnp-ui
+PORTVERSION= 0.1.1
+CATEGORIES= net
+MASTER_SITES= http://www.gupnp.org/sources/${PORTNAME}/
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= Framework for UPnP devices
+
+LIB_DEPENDS= soup-2.4.1:${PORTSDIR}/devel/libsoup \
+ gupnp-1.0:${PORTSDIR}/net/gupnp
+
+USE_PYTHON= yes
+GNU_CONFIGURE= yes
+USE_GNOME= gnomehack intlhack libglade2 gtk20
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>