aboutsummaryrefslogtreecommitdiff
path: root/net/isc-dhcp41-server/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/isc-dhcp41-server/Makefile')
-rw-r--r--net/isc-dhcp41-server/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/net/isc-dhcp41-server/Makefile b/net/isc-dhcp41-server/Makefile
index 3e7a6a6afb40..c6690f36633b 100644
--- a/net/isc-dhcp41-server/Makefile
+++ b/net/isc-dhcp41-server/Makefile
@@ -100,9 +100,9 @@ USES+= perl5
USE_PERL5= run
USE_OPENLDAP= yes
USE_AUTOTOOLS= aclocal libtoolize autoconf autoheader automake
-LIBTOOLIZE_ARG= --copy --force
AUTOMAKE_ARGS= --foreign --add-missing --copy
-CFLAGS+= -I${PREFIX}/include -L${PREFIX}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS+= --with-ldap
.else
PLIST_SUB+= LDAP="@comment "
@@ -112,7 +112,7 @@ PLIST_SUB+= LDAP="@comment "
.if ${PORT_OPTIONS:MLDAP_SSL} && ${PORT_OPTIONS:MLDAP}
USE_OPENSSL= yes
CONFIGURE_ARGS+= --with-ldapcrypto
-CONFIGURE_ENV+= LIBS="-lssl"
+LIBS+= -lssl
# hack to get bsd.openssl.mk included at this late state
.include "${PORTSDIR}/Mk/bsd.openssl.mk"
.endif