aboutsummaryrefslogtreecommitdiff
path: root/net/liferea/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/liferea/Makefile')
-rw-r--r--net/liferea/Makefile53
1 files changed, 4 insertions, 49 deletions
diff --git a/net/liferea/Makefile b/net/liferea/Makefile
index b14e724c9443..2a4655978a42 100644
--- a/net/liferea/Makefile
+++ b/net/liferea/Makefile
@@ -6,15 +6,15 @@
#
PORTNAME= liferea
-PORTVERSION= 1.4.28
-PORTREVISION= 7
+PORTVERSION= 1.6.1
CATEGORIES= net gnome
MASTER_SITES= SF/${PORTNAME}/Liferea%20Stable/${PORTVERSION}
MAINTAINER= pav@FreeBSD.org
COMMENT= Simple RSS/RDF feed reader
-LIB_DEPENDS= sqlite3.8:${PORTSDIR}/databases/sqlite3
+LIB_DEPENDS= sqlite3.8:${PORTSDIR}/databases/sqlite3 \
+ webkit-1.0.13:${PORTSDIR}/www/webkit-gtk2
USE_GNOME= gnomeprefix gnomehack libglade2
USE_GMAKE= yes
@@ -28,12 +28,7 @@ MANLANG= "" pl
GCONF_SCHEMAS= liferea.schemas
INSTALLS_ICONS= yes
-OPTIONS= LIBNOTIFY "Enable libnotify support" on \
- DBUS "Enable dbus support" on \
- GNUTLS "Enable SSL/HTTPS support" on \
- GTKHTML "Use GtkHtml for rendering" on \
- WEBKIT "Use Webkit for rendering" off
-# XULRUNNER "Use Xulrunner for rendering" off
+OPTIONS= LIBNOTIFY "Enable libnotify support" on
.include <bsd.port.pre.mk>
@@ -45,44 +40,4 @@ LIB_DEPENDS+= notify.1:${PORTSDIR}/devel/libnotify
PLIST_SUB+= NOTIFY=""
.endif
-.ifdef WITHOUT_GNUTLS
-CONFIGURE_ARGS+=--disable-gnutls
-.else
-LIB_DEPENDS+= gnutls.40:${PORTSDIR}/security/gnutls
-.endif
-
-.ifdef WITH_GTKHTML
-USE_GNOME+= libgtkhtml
-CONFIGURE_ARGS+=--enable-gtkhtml2
-PLIST_SUB+= GTKHTML=""
-.else
-CONFIGURE_ARGS+=--disable-gtkhtml2
-PLIST_SUB+= GTKHTML="@comment "
-.endif
-
-.ifdef WITH_WEBKIT
-LIB_DEPENDS+= webkit-1.0.13:${PORTSDIR}/www/webkit-gtk2
-CONFIGURE_ARGS+=--enable-webkit
-PLIST_SUB+= WEBKIT=""
-.else
-CONFIGURE_ARGS+=--disable-webkit
-PLIST_SUB+= WEBKIT="@comment "
-.endif
-
-.ifdef WITH_XULRUNNER
-CONFIGURE_ARGS+=--with-gecko=libxul
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libxul/libxul.so:${PORTSDIR}/www/libxul
-RUN_DEPENDS+= ${LOCALBASE}/lib/libxul/libxul.so:${PORTSDIR}/www/libxul
-PLIST_SUB+= XUL=""
-.else
-CONFIGURE_ARGS+=--disable-gecko
-PLIST_SUB+= XUL="@comment "
-.endif
-
-.ifdef WITHOUT_DBUS
-CONFIGURE_ARGS+=--disable-dbus
-.else
-LIB_DEPENDS+= dbus-1.3:${PORTSDIR}/devel/dbus
-.endif
-
.include <bsd.port.post.mk>