aboutsummaryrefslogtreecommitdiff
path: root/net/mpich/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/mpich/Makefile')
-rw-r--r--net/mpich/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/net/mpich/Makefile b/net/mpich/Makefile
index bee75c9ead79..c3b26e1eeef6 100644
--- a/net/mpich/Makefile
+++ b/net/mpich/Makefile
@@ -1,9 +1,9 @@
PORTNAME= mpich
-DISTVERSION= 4.1.3
+DISTVERSION= 4.2.1
CATEGORIES= net parallel
MASTER_SITES= https://www.mpich.org/static/downloads/${DISTVERSION}/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= laurent.chardon@gmail.com
COMMENT= Portable implementation of MPI-1, MPI-2 and MPI-3
WWW= https://www.mpich.org/
@@ -12,18 +12,14 @@ LICENSE_NAME= MPICH
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-# Unfortunately mpicc is BROKEN with sh (Bad substitution on arrays)
-BUILD_DEPENDS= bash:shells/bash
LIB_DEPENDS= libhwloc.so:devel/hwloc2 \
libjson-c.so:devel/json-c \
libfabric.so:net/libfabric \
libslurm.so:sysutils/slurm-wlm \
libepoll-shim.so:devel/libepoll-shim
-RUN_DEPENDS= bash:shells/bash
CONFLICTS= mpd
GNU_CONFIGURE= yes
-GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
INSTALL_TARGET= install-strip
USES= compiler:c11 libtool localbase perl5 pkgconfig python:build
USE_LDCONFIG= yes
@@ -65,6 +61,7 @@ L0_CONFIGURE_OFF= --without-ze
CONFIGURE_ARGS= --enable-fast="" \
--with-libfabric=${LOCALBASE} \
--with-libfabric-include=${WRKDIR}/include \
+ --with-hwloc=${LOCALBASE} \
pkgconfigdir="${PREFIX}/libdata/pkgconfig" \
MPICHLIB_CFLAGS="${CFLAGS}" \
CFLAGS="-I${LOCALBASE}/include/json-c ${CFLAGS_F2018}" \
@@ -77,6 +74,8 @@ CONFIGURE_ARGS= --enable-fast="" \
LIBS="-L${LOCALBASE}/lib -lepoll-shim -ljson-c -lm" \
BASH_SHELL=${LOCALBASE}/bin/bash
+PORTDOCS= *
+
.include <bsd.port.pre.mk>
.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} == 170
@@ -114,10 +113,10 @@ post-extract:
${FIND} ${WRKSRC} -name "*.orig" -delete
post-patch:
- ${RM} -r ${WRKSRC}/www
# To avoid pollution from ${LOCALBASE}/include, set up the build to look in
# ${WRKDIR} for libfabric include/rdma/ header files (see --with-libfabric
# configure args).
+# PR: 265684
${MKDIR} ${WRKDIR}/include && ${LN} -s ${LOCALBASE}/include/rdma ${WRKDIR}/include/
.include <bsd.port.post.mk>