aboutsummaryrefslogtreecommitdiff
path: root/net/netatalk-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/netatalk-devel/Makefile')
-rw-r--r--net/netatalk-devel/Makefile35
1 files changed, 8 insertions, 27 deletions
diff --git a/net/netatalk-devel/Makefile b/net/netatalk-devel/Makefile
index 81bc965992e9..9f34778e9889 100644
--- a/net/netatalk-devel/Makefile
+++ b/net/netatalk-devel/Makefile
@@ -6,23 +6,21 @@
#
PORTNAME= netatalk
-PORTVERSION= 1.6.4
-PORTREVISION= 1
-PORTEPOCH= 1
+PORTVERSION= 2.0.b1
CATEGORIES= net print
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= netatalk
+DISTNAME= ${PORTNAME}-2.0-beta1
MAINTAINER= marcus@FreeBSD.org
COMMENT= File and print server for AppleTalk networks
-.if !defined(WITHOUT_CNID)
-LIB_DEPENDS= db3.3:${PORTSDIR}/databases/db3
-.endif
+LIB_DEPENDS= db41.1:${PORTSDIR}/databases/db41
.if defined(WITH_SRVLOC)
LIB_DEPENDS+= slp.1:${PORTSDIR}/net/openslp
.endif
+NO_LATEST_LINK= yes
USE_BZIP2= yes
CONFIGURE_ARGS+= --with-tcp-wrappers \
--with-pkgconfdir=${PREFIX}/etc
@@ -38,29 +36,13 @@ PLIST_SUB+= NETATALKPAM="@comment "
# pickup afpd servers in the network.
CONFIGURE_ARGS+= --enable-srvloc=${LOCALBASE}
.endif
-.if defined(WITHOUT_CNID)
-# Configure old LAST DID support. By default, the new CNID persistent DID
-# calculation scheme is used. However, if you wish to revert back to the old
-# 1.5.x default scheme, specify WITHOUT_CNID
-CONFIGURE_ARGS+= --with-did=last
-PLIST_SUB+= NETATALKCNID="@comment "
-.else
-# This method of DID calculation is not persistent, but has been tested to
-# work with MacOS X (10.0.3-10.1.3) as well as MacOS 7-9.2.2.
-CONFIGURE_ARGS+= --with-did=cnid \
- --with-bdb=${LOCALBASE}
-PLIST_SUB+= NETATALKCNID=""
-.endif
+CONFIGURE_ARGS+= --with-bdb=${LOCALBASE}
.if defined (WITH_TIMELORD)
CONFIGURE_ARGS+= --enable-timelord
PLIST_SUB+= TIMELORD=""
.else
PLIST_SUB+= TIMELORD="@comment "
.endif
-.if defined (WITH_MANGLING) && !defined (WITHOUT_CNID)
-# Enable long file name mangling support (requires CNID).
-CONFIGURE_ARGS+= --with-mangling
-.endif
GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
@@ -79,18 +61,17 @@ MAN3= atalk_aton.3 nbp_name.3
MAN4= atalk.4
MAN5= AppleVolumes.default.5 afpd.conf.5 atalkd.conf.5 \
netatalk.conf.5 papd.conf.5
-MAN8= afpd.8 atalkd.8 papd.8 papstatus.8 psf.8 timelord.8
+MAN8= afpd.8 atalkd.8 cnid_dbd.8 cnid_metad.8 papd.8 papstatus.8 \
+ psf.8 timelord.8
-CONFLICTS= bigloo-2.* cap-6.0.* tct-1.*
+CONFLICTS= bigloo-2.* cap-6.0.* tct-1.* netatalk-1*
pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} "Netatalk has the following tunable options:"
- @${ECHO_MSG} " WITHOUT_CNID=yes Turns off CNID persistent DID support"
@${ECHO_MSG} " WITH_SRVLOC=yes Enable Service Location Protocol support"
@${ECHO_MSG} " WITH_PAM=yes Enable PAM support"
@${ECHO_MSG} " WITH_TIMELORD=yes Enable Timelord network time service"
- @${ECHO_MSG} " WITH_MANGLING=yes Enable long file name mangling support (requires CNID)"
@${ECHO_MSG} ""
@${ECHO_MSG} "See Netatalk's Makefile for more details on some of these options."
@${ECHO_MSG} ""