aboutsummaryrefslogtreecommitdiff
path: root/net/ser/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/ser/Makefile')
-rw-r--r--net/ser/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/net/ser/Makefile b/net/ser/Makefile
index 591de27c9407..72dbe2590e89 100644
--- a/net/ser/Makefile
+++ b/net/ser/Makefile
@@ -44,6 +44,12 @@ PLIST_SUB+= POSTGRESQL="@comment "
MAKE_ENV+= POSTGRESQL=postgres
.endif
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "sparc64" || ${ARCH} == "ia64"
+BROKEN= "Does not compile completely on sparc64 or ia64"
+.endif
+
post-install:
${SED} 's|%%LOCALBASE%%|${LOCALBASE}|g ; s|%%PREFIX%%|${PREFIX}|g' \
${WRKSRC}/modules/acc/etc/radiusclient.conf > \
@@ -59,4 +65,4 @@ post-install:
${PREFIX}/etc/ser/radiusclient.conf; \
fi
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>