aboutsummaryrefslogtreecommitdiff
path: root/net/v6eval/files/patch-bin-remotes-unknown-Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/v6eval/files/patch-bin-remotes-unknown-Makefile')
-rw-r--r--net/v6eval/files/patch-bin-remotes-unknown-Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/net/v6eval/files/patch-bin-remotes-unknown-Makefile b/net/v6eval/files/patch-bin-remotes-unknown-Makefile
new file mode 100644
index 000000000000..180a6bd8988c
--- /dev/null
+++ b/net/v6eval/files/patch-bin-remotes-unknown-Makefile
@@ -0,0 +1,23 @@
+--- bin/remotes/unknown/Makefile.orig 2005-11-10 12:54:12.000000000 +0900
++++ bin/remotes/unknown/Makefile 2013-06-17 00:39:47.000000000 +0900
+@@ -43,8 +43,8 @@
+
+ PRODUCT=unknown
+
+-PREFIX=/usr/local/v6eval
+-RMTDIR=$(PREFIX)/bin/$(PRODUCT)
++PREFIX?=/usr/local
++RMTDIR=$(PREFIX)/v6eval/bin/$(PRODUCT)
+ REMOTES= cleardefr.rmt \
+ clearmtu.rmt \
+ clearnc.rmt \
+@@ -101,6 +101,6 @@
+ clean:
+
+ install:
+- install -d -o bin -g bin -m 755 $(PREFIX)/bin
+- install -d -o bin -g bin -m 755 $(RMTDIR)
+- install -c -o bin -g bin -m 555 $(REMOTES) $(RMTDIR)
++ install -d -m 555 $(PREFIX)/v6eval/bin
++ install -d -m 555 $(RMTDIR)
++ ${BSD_INSTALL_SCRIPT} $(REMOTES) $(RMTDIR)