aboutsummaryrefslogtreecommitdiff
path: root/net/x2goclient/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/x2goclient/Makefile')
-rw-r--r--net/x2goclient/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/net/x2goclient/Makefile b/net/x2goclient/Makefile
index d54da7f767e0..4f4ebeabd8e5 100644
--- a/net/x2goclient/Makefile
+++ b/net/x2goclient/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= x2goclient
-PORTVERSION= 4.0.4.0
+PORTVERSION= 4.0.5.0
CATEGORIES= net
MASTER_SITES= http://code.x2go.org/releases/source/x2goclient/
@@ -10,6 +10,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Qt client for the X2Go system
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
# Avoid clash with libssh from base
BUILD_DEPENDS= ${LOCALBASE}/lib/libssh.so:${PORTSDIR}/security/libssh
@@ -38,11 +39,11 @@ post-patch:
${REINPLACE_CMD} -e \
's|Q_OS_LINUX|Q_OS_UNIX| ; \
/<linux\/fs.h>/s|^|//| ; \
- /#define USELDAP/s|^|//|'
+ /#define USELDAP/s|^|//| ; \
+ s|/usr/local/bin|${LOCALBASE}/bin|'
pre-build:
- @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} \
- ${MAKEFILE} compiler_TSQM_make_all)
+ @(cd ${WRKSRC} && ${DO_MAKE_BUILD} compiler_TSQM_make_all)
do-install:
(cd ${WRKSRC} && ${INSTALL_PROGRAM} x2goclient \