aboutsummaryrefslogtreecommitdiff
path: root/net/xrdp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/xrdp/Makefile')
-rw-r--r--net/xrdp/Makefile25
1 files changed, 12 insertions, 13 deletions
diff --git a/net/xrdp/Makefile b/net/xrdp/Makefile
index a95d89d2283a..c59d4979a8b1 100644
--- a/net/xrdp/Makefile
+++ b/net/xrdp/Makefile
@@ -2,19 +2,18 @@
# $FreeBSD$
PORTNAME= xrdp
-PORTVERSION= 0.6.0
-PORTREVISION= 4
+PORTVERSION= 0.6.1
+PORTREVISION= 0
PORTEPOCH= 1
CATEGORIES= net
-MASTER_SITES= SF/xrdp/xrdp/${PORTVERSION}
-DISTNAME= ${PORTNAME}-v${PORTVERSION}
+MASTER_SITES= GH
DIST_SUBDIR?= ${PORTNAME}
PATCH_SITES= http://www.club.kyutech.ac.jp/~meta/patches/xrdp/0.6.0/ \
http://key2.jp/~meta/patches/xrdp/0.6.0/
MAINTAINER= meta+ports@vmeta.jp
-COMMENT= An open source Remote Desktop Protocol (RDP) server
+COMMENT= Open source Remote Desktop Protocol (RDP) server
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
@@ -24,6 +23,11 @@ USE_XORG= x11 xfixes
USE_AUTOTOOLS= autoconf:env automake:env libtool
GNU_CONFIGURE= yes
USE_RC_SUBR= xrdp
+USE_GITHUB= yes
+GH_ACCOUNT= FreeRDP
+GH_PROJECT= xrdp
+GH_COMMIT= 5d53758
+GH_TAGNAME= ${GH_COMMIT}
CONFIGURE_ARGS= --localstatedir=/var --enable-freerdp1
LDFLAGS+= -L${LOCALBASE}/lib
@@ -31,7 +35,7 @@ CPPFLAGS+= -I${LOCALBASE}/include
CONFLICTS= xrdp-devel-[0-9]*
BUILD_DEPENDS+= freerdp>=1.0.2:${PORTSDIR}/net/freerdp
-USE_LDCONFIG= ${PREFIX}/lib/xrdp
+USE_LDCONFIG= ${STAGEDIR}${PREFIX}/lib/xrdp
OPTIONS_DEFINE= DEBUG JP106
OPTIONS_DEFAULT= JP106 TIGERVNC
@@ -43,7 +47,6 @@ TIGHTVNC_DESC= Use TightVNC
TRIDIAVNC_DESC= Use TridiaVNC
JP106_DESC= Install Japanese JP106 keymap
-NO_STAGE= yes
.include <bsd.port.options.mk>
# Which Xserver to use
@@ -76,9 +79,6 @@ PLIST_SUB+= JP106=""
PLIST_SUB+= JP106="@comment "
.endif
-MAN5= sesman.ini.5 xrdp.ini.5
-MAN8= xrdp-sesman.8 xrdp-sesrun.8 xrdp.8
-
SUB_FILES= pkg-message
post-patch:
@@ -91,10 +91,9 @@ pre-configure:
post-install:
.for f in sesman.ini startwm.sh xrdp.ini
- @if [ ! -f ${PREFIX}/etc/xrdp/$f ]; then \
- ${CP} -p ${PREFIX}/etc/xrdp/$f.sample ${PREFIX}/etc/xrdp/$f ; \
+ @if [ ! -f ${STAGEDIR}${PREFIX}/etc/xrdp/$f ]; then \
+ ${CP} -p ${STAGEDIR}${PREFIX}/etc/xrdp/$f.sample ${STAGEDIR}${PREFIX}/etc/xrdp/$f ; \
fi
.endfor
- @${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
.include <bsd.port.mk>