aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/pear-Horde_Kolab_Server/Makefile10
-rw-r--r--net/pear-Horde_Kolab_Session/Makefile5
-rw-r--r--net/pear-Horde_Ldap/Makefile5
-rw-r--r--net/pear-Horde_Rpc/Makefile5
-rw-r--r--net/pear-Horde_Scribe/Makefile5
-rw-r--r--net/pear-Horde_Socket_Client/Makefile5
-rw-r--r--net/pear-Horde_Url/Makefile5
7 files changed, 15 insertions, 25 deletions
diff --git a/net/pear-Horde_Kolab_Server/Makefile b/net/pear-Horde_Kolab_Server/Makefile
index 468358844110..b1bbaf80733a 100644
--- a/net/pear-Horde_Kolab_Server/Makefile
+++ b/net/pear-Horde_Kolab_Server/Makefile
@@ -9,6 +9,7 @@ PKGNAMEPREFIX= pear-
MAINTAINER= horde@FreeBSD.org
COMMENT= Horde library for manipulating the Kolab user database
+USES= horde
USE_PHP= hash
USE_HORDE_RUN= Horde_Auth \
Horde_Exception
@@ -20,11 +21,6 @@ LDAP_DESC= Enable LDAP support
# Not required but we want it
USE_HORDE_RUN+= Horde_Date
-.include <bsd.port.pre.mk>
+LDAP_USE= HORDE_RUN=Horde_Ldap
-.if ${PORT_OPTIONS:MLDAP}
-USE_HORDE_RUN+= Horde_Ldap
-.endif
-
-.include "${PORTSDIR}/devel/pear-channel-horde/bsd.horde.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-Horde_Kolab_Session/Makefile b/net/pear-Horde_Kolab_Session/Makefile
index 77345695e2c4..2908c4d8bdca 100644
--- a/net/pear-Horde_Kolab_Session/Makefile
+++ b/net/pear-Horde_Kolab_Session/Makefile
@@ -8,12 +8,11 @@ CATEGORIES= net www pear
MAINTAINER= horde@FreeBSD.org
COMMENT= Horde library for managing an active Kolab session
+USES= horde
USE_HORDE_RUN= Horde_Exception
# Optional but we want it
USE_HORDE_RUN+= Horde_Kolab_Server \
Horde_Log
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear-channel-horde/bsd.horde.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-Horde_Ldap/Makefile b/net/pear-Horde_Ldap/Makefile
index bb3b70b512d5..58e849d14669 100644
--- a/net/pear-Horde_Ldap/Makefile
+++ b/net/pear-Horde_Ldap/Makefile
@@ -8,10 +8,9 @@ CATEGORIES= net www pear
MAINTAINER= horde@FreeBSD.org
COMMENT= Horde LDAP libraries
+USES= horde
USE_PHP= ldap
USE_HORDE_RUN= Horde_Exception \
Horde_Util
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear-channel-horde/bsd.horde.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-Horde_Rpc/Makefile b/net/pear-Horde_Rpc/Makefile
index da2bb6464cea..0e243ecea640 100644
--- a/net/pear-Horde_Rpc/Makefile
+++ b/net/pear-Horde_Rpc/Makefile
@@ -7,6 +7,7 @@ CATEGORIES= net www pear
MAINTAINER= horde@FreeBSD.org
COMMENT= Horde RPC API
+USES= horde
USE_HORDE_RUN= Horde_Core \
Horde_Dav \
Horde_Exception \
@@ -23,6 +24,4 @@ USE_HORDE_RUN+= Horde_ActiveSync \
Horde_SyncMl \
Horde_Http
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear-channel-horde/bsd.horde.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-Horde_Scribe/Makefile b/net/pear-Horde_Scribe/Makefile
index 72c86d2e2f2c..1fdea40c0c98 100644
--- a/net/pear-Horde_Scribe/Makefile
+++ b/net/pear-Horde_Scribe/Makefile
@@ -8,8 +8,7 @@ CATEGORIES= net www pear
MAINTAINER= horde@FreeBSD.org
COMMENT= Horde Scribe client
+USES= horde
USE_HORDE_RUN= Horde_Thrift
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear-channel-horde/bsd.horde.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-Horde_Socket_Client/Makefile b/net/pear-Horde_Socket_Client/Makefile
index 606ceb270b80..44fe19855c26 100644
--- a/net/pear-Horde_Socket_Client/Makefile
+++ b/net/pear-Horde_Socket_Client/Makefile
@@ -8,8 +8,7 @@ CATEGORIES= net www pear
MAINTAINER= horde@FreeBSD.org
COMMENT= Horde Socket Client
+USES= horde
USE_HORDE_RUN= Horde_Exception
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear-channel-horde/bsd.horde.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-Horde_Url/Makefile b/net/pear-Horde_Url/Makefile
index ff11d60552c2..45b506b50de5 100644
--- a/net/pear-Horde_Url/Makefile
+++ b/net/pear-Horde_Url/Makefile
@@ -8,8 +8,7 @@ CATEGORIES= net www pear
MAINTAINER= horde@FreeBSD.org
COMMENT= Horde URL class
+USES= horde
USE_HORDE_RUN= Horde_Exception
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear-channel-horde/bsd.horde.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>