aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/cagibi/Makefile2
-rw-r--r--net/crtmpserver/Makefile3
-rw-r--r--net/freerdp/Makefile2
-rw-r--r--net/kio-upnp-ms/Makefile2
-rw-r--r--net/knemo-kde4/Makefile2
-rw-r--r--net/kwooty/Makefile2
-rw-r--r--net/libmxp/Makefile2
-rw-r--r--net/libproxy/Makefile2
-rw-r--r--net/qtweetlib/Makefile2
-rw-r--r--net/smb4k-kde4/Makefile2
-rw-r--r--net/userfw/Makefile3
11 files changed, 11 insertions, 13 deletions
diff --git a/net/cagibi/Makefile b/net/cagibi/Makefile
index ffd194ed8ad4..cdaa8890308c 100644
--- a/net/cagibi/Makefile
+++ b/net/cagibi/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= KDE SSDP/uPNP proxy
USE_BZIP2= yes
-USE_CMAKE= yes
+USES= cmake
USE_KDE4= automoc4
USE_QT4= corelib network xml dbus \
qmake_build moc_build rcc_build uic_build
diff --git a/net/crtmpserver/Makefile b/net/crtmpserver/Makefile
index b20afe944b56..407cc77b885c 100644
--- a/net/crtmpserver/Makefile
+++ b/net/crtmpserver/Makefile
@@ -15,9 +15,8 @@ WRKSRC= ${WRKDIR}/crtmpserver-545
BROKEN= fails to build
-USE_CMAKE= yes
+USES= cmake:outsource
CMAKE_ENV= "COMPILE_STATIC=1"
-CMAKE_OUTSOURCE= yes
CMAKE_SOURCE_PATH= ${WRKSRC}/builders/cmake
CMAKE_ARGS= -DCRTMPSERVER_INSTALL_PREFIX:STRING=${PREFIX} -DTEMP_FRAMEWORK_VER=0.545
diff --git a/net/freerdp/Makefile b/net/freerdp/Makefile
index f48e2b6093ec..e0c8817987de 100644
--- a/net/freerdp/Makefile
+++ b/net/freerdp/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USE_PKGCONFIG= build
USE_OPENSSL= yes
USE_LDCONFIG= yes
-USE_CMAKE= yes
+USES= cmake
USE_GITHUB= yes
GH_ACCOUNT= FreeRDP
GH_PROJECT= FreeRDP
diff --git a/net/kio-upnp-ms/Makefile b/net/kio-upnp-ms/Makefile
index 9e52b76927e0..dffd18710733 100644
--- a/net/kio-upnp-ms/Makefile
+++ b/net/kio-upnp-ms/Makefile
@@ -20,7 +20,7 @@ COMMENT= KIO slave to access UPnP MediaServers
LIB_DEPENDS= HUpnp.1:${PORTSDIR}/net/hupnp
USE_BZIP2= yes
-USE_CMAKE= yes
+USES= cmake
USE_KDE4= automoc4 kdehier kdeprefix kdelibs
USE_QT4= corelib network xml dbus gui \
qmake_build moc_build rcc_build uic_build
diff --git a/net/knemo-kde4/Makefile b/net/knemo-kde4/Makefile
index 92bce24c5ac2..7095f572d956 100644
--- a/net/knemo-kde4/Makefile
+++ b/net/knemo-kde4/Makefile
@@ -12,7 +12,7 @@ COMMENT= KDE network monitor
LATEST_LINK= ${PORTNAME}-kde4
USE_BZIP2= yes
-USE_CMAKE= yes
+USES= cmake
USE_QT4= qmake_build moc_build uic_build rcc_build
USE_KDE4= kdeprefix kdelibs workspace automoc4
diff --git a/net/kwooty/Makefile b/net/kwooty/Makefile
index c9e7fa77c454..75a1ec21288c 100644
--- a/net/kwooty/Makefile
+++ b/net/kwooty/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= ${LOCALBASE}/bin/unrar:${PORTSDIR}/archivers/unrar \
USE_KDE4= kdelibs kdehier kdeprefix automoc4 workspace
USE_QT4= qmake_build moc_build rcc_build uic_build
MAKE_JOBS_SAFE= yes
-USE_CMAKE= yes
+USES= cmake
USE_LDCONFIG= yes
post-patch:
diff --git a/net/libmxp/Makefile b/net/libmxp/Makefile
index b854d5bbf335..4a0fd2295499 100644
--- a/net/libmxp/Makefile
+++ b/net/libmxp/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= http://www.kmuddy.com/libmxp/files/
MAINTAINER= johans@FreeBSD.org
COMMENT= Parser for the MUD eXtension protocol
-USE_CMAKE= yes
+USES= cmake
USE_LDCONFIG= yes
post-patch:
diff --git a/net/libproxy/Makefile b/net/libproxy/Makefile
index d9e867cc9174..126cc2b0caaf 100644
--- a/net/libproxy/Makefile
+++ b/net/libproxy/Makefile
@@ -14,7 +14,7 @@ MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
MAINTAINER= gnome@FreeBSD.org
COMMENT?= Library that provides automatic proxy configuration management
-USE_CMAKE= yes
+USES= cmake
PLIST_SUB+= VERSION=${PORTVERSION}
diff --git a/net/qtweetlib/Makefile b/net/qtweetlib/Makefile
index 74b2c0a466c2..9cb3a30bb71b 100644
--- a/net/qtweetlib/Makefile
+++ b/net/qtweetlib/Makefile
@@ -18,7 +18,7 @@ GH_COMMIT= 2af0b78
GH_PROJECT= QTweetLib
GH_TAGNAME= ${PORTVERSION}
-USE_CMAKE= yes
+USES= cmake
USE_GITHUB= yes
USE_LDCONFIG= yes
USE_QT4= gui moc_build network qmake_build rcc_build uic_build
diff --git a/net/smb4k-kde4/Makefile b/net/smb4k-kde4/Makefile
index 07fdacc65c98..1cf3ec240793 100644
--- a/net/smb4k-kde4/Makefile
+++ b/net/smb4k-kde4/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= sudo:${PORTSDIR}/security/sudo \
SAMBA_PORT?= net/samba36
-USE_CMAKE= yes
+USES= cmake
USE_GETTEXT= yes
USE_BZIP2= yes
USE_LDCONFIG= ${PREFIX}/lib ${PREFIX}/lib/kde4
diff --git a/net/userfw/Makefile b/net/userfw/Makefile
index 00fabe458beb..0d9536d50fb2 100644
--- a/net/userfw/Makefile
+++ b/net/userfw/Makefile
@@ -19,9 +19,8 @@ COMMENT= Modular packet filter
LICENSE= BSD
USE_XZ= yes
-USE_CMAKE= yes
+USES= cmake:outsource
USE_LDCONFIG= yes
-CMAKE_OUTSOURCE= yes
KMODDIR?= /boot/modules
PLIST_SUB+= KMODDIR=${KMODDIR}