aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/freebsd-bugzilla-cli/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ports-mgmt/freebsd-bugzilla-cli/Makefile')
-rw-r--r--ports-mgmt/freebsd-bugzilla-cli/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/ports-mgmt/freebsd-bugzilla-cli/Makefile b/ports-mgmt/freebsd-bugzilla-cli/Makefile
new file mode 100644
index 000000000000..415b7555b42e
--- /dev/null
+++ b/ports-mgmt/freebsd-bugzilla-cli/Makefile
@@ -0,0 +1,29 @@
+# Created by: Philip M. Gollucci <pgollucci@p6m7g8.com>
+# $FreeBSD$
+
+PORTNAME= freebsd-bugzilla-cli
+PORTVERSION= 0.0.1
+CATEGORIES= ports-mgmt
+MASTER_SITES= GH
+
+MAINTAINER= pgollucci@FreeBSD.org
+COMMENT= Interact with the FreeBSD bugzilla instance
+
+LICENSE= APACHE20
+
+OPTIONS_GROUP= BACKEND
+OPTIONS_GROUP_BACKEND= PYBUGZ
+OPTIONS_SET= PYBUGZ
+OPTIONS_SUB= yes
+
+PYBUGZ_DESC= use devel/pybugz for bugzilla interface
+PYBUGZ_RUN_DEPENDS= bugz:${PORTSDIR}/devel/pybugz
+
+DATADIR= ${PREFIX}/share/bz
+
+USE_GITHUB= yes
+GH_ACCOUNT= pgollucci
+
+NO_BUILD= yes
+
+.include <bsd.port.mk>