aboutsummaryrefslogtreecommitdiff
path: root/print/libgnomeprintmm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/libgnomeprintmm/Makefile')
-rw-r--r--print/libgnomeprintmm/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/print/libgnomeprintmm/Makefile b/print/libgnomeprintmm/Makefile
index d91a2a9737f1..e023ef869f8d 100644
--- a/print/libgnomeprintmm/Makefile
+++ b/print/libgnomeprintmm/Makefile
@@ -21,6 +21,7 @@ BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
+USE_REINPLACE= yes
USE_GCC= 3.4
USE_GNOME= gnomeprefix gnomehack libgnomeprint
INSTALLS_SHLIB= yes
@@ -29,6 +30,10 @@ CONFIGURE_ARGS= --enable-static
PLIST_SUB= VERSION="2.5" API_VERSION="2.6"
+post-patch:
+ @${REINPLACE_CMD} -e "s|\(-lglibmm\)|-L\$$(GMM_PROCDIR)/../.. \1|" \
+ ${WRKSRC}/tools/extra_defs_gen/Makefile.in
+
patch-autotools:
@(cd ${PATCH_WRKSRC}; \
for file in ${LIBTOOLFILES}; do \