aboutsummaryrefslogtreecommitdiff
path: root/print/lilypond-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/lilypond-devel/Makefile')
-rw-r--r--print/lilypond-devel/Makefile32
1 files changed, 18 insertions, 14 deletions
diff --git a/print/lilypond-devel/Makefile b/print/lilypond-devel/Makefile
index 49a5cf4152c7..029d529c9719 100644
--- a/print/lilypond-devel/Makefile
+++ b/print/lilypond-devel/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= lilypond
-DISTVERSION= 2.23.0
+DISTVERSION= 2.23.1
CATEGORIES= print audio
MASTER_SITES= http://lilypond.org/download/source/v${DISTVERSION:R}/
PKGNAMESUFFIX= -devel
@@ -26,13 +26,12 @@ BUILD_DEPENDS= bash:shells/bash \
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
libgmp.so:math/gmp \
- libguile.so:lang/guile1 \
libltdl.so:devel/libltdl
RUN_DEPENDS= ${LOCALBASE}/share/fonts/dejavu/DejaVuSans-Bold.ttf:x11-fonts/dejavu \
mftrace:print/mftrace
-USES= bison:build compiler:c++11-lib ghostscript gmake gnome \
- perl5 pkgconfig python:3.5+
+USES= bison:build compiler:c++11-lib ghostscript gmake gnome perl5 \
+ pkgconfig python:3.5+
USE_CXXSTD= c++11
USE_GNOME= pango
USE_PERL5= build
@@ -51,22 +50,27 @@ ALL_TARGET= all
BINARY_ALIAS= python=${PYTHON_VERSION}
INFO= lilypond-changes \
- lilypond-contributor \
- lilypond-essay \
- lilypond-extending \
- lilypond-internals \
- lilypond-learning \
- lilypond-notation \
- lilypond-snippets \
- lilypond-usage \
- music-glossary
+ lilypond-contributor \
+ lilypond-essay \
+ lilypond-extending \
+ lilypond-internals \
+ lilypond-learning \
+ lilypond-notation \
+ lilypond-snippets \
+ lilypond-usage \
+ music-glossary
PLIST_SUB= DISTVERSION=${DISTVERSION}
-OPTIONS_DEFINE= URW NLS
+OPTIONS_DEFINE= GUILE2 NLS URW
OPTIONS_SUB= yes
+GUILE2_DESC= Use guile2 (will incur some performance penalty)
URW_DESC= Use bundled URW fonts
+GUILE2_LIB_DEPENDS= libgc-threaded.so:devel/boehm-gc-threaded \
+ libguile-2.2.so:lang/guile2
+GUILE2_LIB_DEPENDS_OFF= libguile.so:lang/guile1
+
NLS_USES= gettext
URW_BUILD_DEPENDS= urw-core35-fonts>0:x11-fonts/urw-core35-fonts