aboutsummaryrefslogtreecommitdiff
path: root/science/cp2k/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/cp2k/Makefile')
-rw-r--r--science/cp2k/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/science/cp2k/Makefile b/science/cp2k/Makefile
index 0b6039879acd..33319dd175be 100644
--- a/science/cp2k/Makefile
+++ b/science/cp2k/Makefile
@@ -2,7 +2,7 @@
PORTNAME= cp2k
DISTVERSION= 6.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= science
MASTER_SITES= SF/${PORTNAME}/
@@ -45,12 +45,14 @@ SERIAL_VARS= VERSION=sopt
OPENMP_VARS= VERSION=ssmp
MPI_VARS= VERSION=popt
-MPI_LIB_DEPENDS= libmpich.so:net/mpich2 \
+MPI_LIB_DEPENDS= libmpich.so:net/mpich \
libscalapack.so:math/scalapack
+MPI_LDFLAGS= -lmpifort
OPENMP_MPI_DESC= Enable both OpenMP and MPI
OPENMP_MPI_VARS= VERSION=psmp
OPENMP_MPI_LIB_DEPENDS= ${MPI_LIB_DEPENDS}
+OPENMP_MPI_LDFLAGS= ${MPI_LDFLAGS}
PLIST_FILES= bin/${PORTNAME}