aboutsummaryrefslogtreecommitdiff
path: root/science/massxpert/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/massxpert/Makefile')
-rw-r--r--science/massxpert/Makefile26
1 files changed, 17 insertions, 9 deletions
diff --git a/science/massxpert/Makefile b/science/massxpert/Makefile
index 61bfcb02e3d9..4ef64b019cf4 100644
--- a/science/massxpert/Makefile
+++ b/science/massxpert/Makefile
@@ -1,25 +1,33 @@
-# New ports collection makefile for: massxpert
-# Date created: 2010-05-14
-# Whom: Gvozdikov Veniamin <g.veniamin@googlemail.com>
-#
+# Created by: Gvozdikov Veniamin <g.veniamin@googlemail.com>
# $FreeBSD$
-#
PORTNAME= massxpert
-PORTVERSION= 3.1.0
-PORTREVISION= 1
+PORTVERSION= 3.3.0
CATEGORIES= science
MASTER_SITES= http://download.tuxfamily.org/massxpert/source/
MAINTAINER= g.veniamin@googlemail.com
COMMENT= The massXpert software for (bio)chemists
+LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
+ pcre:${PORTSDIR}/devel/pcre \
+ png15:${PORTSDIR}/graphics/png \
+ freetype:${PORTSDIR}/print/freetype2 \
+ expat:${PORTSDIR}/textproc/expat2 \
+ fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
+ xcb:${PORTSDIR}/x11/libxcb
+
LICENSE= GPLv3
USE_CMAKE= yes
-USE_LDCONFIG= yes
-USE_QT4= gui xml rcc_build qmake_build uic_build moc_build \
+USE_GETTEXT= yes
+USE_ICONV= yes
+USE_XORG= ice sm x11 xau xdmcp xext xrender
+USE_GNOME= glib20
+USE_QT4= corelib gui xml rcc_build qmake_build uic_build moc_build \
svg
+USE_LDCONFIG= yes
+MAKE_JOBS_UNSAFE= yes
MAN7= massxpert-data.7
MAN1= massxpert.1