aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
Diffstat (limited to 'science')
-rw-r--r--science/agrum/Makefile2
-rw-r--r--science/cantera/Makefile2
-rw-r--r--science/cdo/Makefile9
-rw-r--r--science/dftbplus/Makefile2
-rw-r--r--science/libctl/Makefile2
-rw-r--r--science/libtensorflow1/Makefile5
-rw-r--r--science/libtensorflow1/files/extra-patch-third_party_repo.bzl25
-rw-r--r--science/siesta/Makefile2
-rw-r--r--science/simlib/Makefile2
-rw-r--r--science/step/Makefile1
-rw-r--r--science/zotero/Makefile1
11 files changed, 3 insertions, 50 deletions
diff --git a/science/agrum/Makefile b/science/agrum/Makefile
index d52987962bd8..9466d6058570 100644
--- a/science/agrum/Makefile
+++ b/science/agrum/Makefile
@@ -9,8 +9,6 @@ WWW= https://agrum.gitlab.io/
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_FreeBSD_12= requires modern C++ compiler: error: invalid value 'c++2b'
-
USES= cmake compiler:c++20-lang shebangfix # the 'act' executable uses 'python' and is broken, when act is broken CMakeLists.txt builds with default configuration which is fine
USE_LDCONFIG= yes
diff --git a/science/cantera/Makefile b/science/cantera/Makefile
index 909396e8e3e5..fc0b817aab88 100644
--- a/science/cantera/Makefile
+++ b/science/cantera/Makefile
@@ -27,8 +27,6 @@ USE_GITHUB= yes
GH_ACCOUNT= Cantera
GH_TUPLE= LLNL:sundials:887af43:sundials/ext/sundials # bundled sundials is only needed for the Octave option
-CXXFLAGS+= ${CXXFLAGS_${OPSYS}_${OSREL:R}}
-CXXFLAGS_FreeBSD_12= -D_GNU_SOURCE
MAKE_ARGS= system_eigen='y' \
system_sundials='n' \
system_fmt='y' \
diff --git a/science/cdo/Makefile b/science/cdo/Makefile
index c6360fab1c7c..cf4a2a751fea 100644
--- a/science/cdo/Makefile
+++ b/science/cdo/Makefile
@@ -40,6 +40,7 @@ MAKE_JOBS_UNSAFE= yes
TEST_TARGET= check
USE_CXXSTD= c++17
USE_LDCONFIG= yes
+CFLAGS+= -DPTHREAD_MUTEXATTR
CGRIBEX_CONFIGURE_WITH= cgribex
CGRIBEX_LIB_DEPENDS= libcgribex.so:science/cgribex
@@ -60,12 +61,6 @@ UDUNITS_LIB_DEPENDS= libudunits2.so:science/udunits
UUID_CONFIGURE_OFF= ac_cv_func_uuid_create=no ac_cv_have_decl_uuid_create=no ac_cv_have_decl_uuid_generate=no ac_cv_lib_uuid_uuid_generate=no
UUID_LIB_DEPENDS= libuuid.so:misc/e2fsprogs-libuuid
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} != "sparc64"
-CFLAGS+= -DPTHREAD_MUTEXATTR
-.endif
-
post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS = / s| contrib||' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|$$(libdir)/\($$$$pkgconfigfile\)|${PREFIX}/libdata/\1|' ${WRKSRC}/libcdi/src/Makefile.in
@@ -77,4 +72,4 @@ post-install:
test-NETCDF-on:
@cd ${WRKSRC}/ && ${SETENV} CDO_PATH=src/cdo src/cdotest
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/science/dftbplus/Makefile b/science/dftbplus/Makefile
index 9fc886c35e92..c4e9cabba2a8 100644
--- a/science/dftbplus/Makefile
+++ b/science/dftbplus/Makefile
@@ -10,8 +10,6 @@ WWW= https://dftbplus.org/
LICENSE= GPLv3 # main code is under LGPL3+, the bundled dftd3-lib is under GPLv1+, this makes the result GPLv3 (based on https://www.gnu.org/licenses/gpl-faq.html#AllCompatibility)
BROKEN_aarch64= Lack of IEEE754 support in gcc causes "Cannot find an intrinsic module named 'ieee_arithmetic'", see bug\#255890
-BROKEN_FreeBSD_12_powerpc= Lack of IEEE754 support in gcc causes "Cannot find an intrinsic module named 'ieee_arithmetic'", see bug\#255890
-BROKEN_FreeBSD_12_powerpc64= Lack of IEEE754 support in gcc causes "Cannot find an intrinsic module named 'ieee_arithmetic'", see bug\#255890
LIB_DEPENDS= libblas.so:math/blas \
liblapack.so:math/lapack \
diff --git a/science/libctl/Makefile b/science/libctl/Makefile
index 2b76d8cb2ee5..2c21d1f1bd9f 100644
--- a/science/libctl/Makefile
+++ b/science/libctl/Makefile
@@ -10,8 +10,6 @@ WWW= https://libctl.readthedocs.io/en/latest/
LICENSE= GPLv2
-BROKEN_sparc64= does not build
-
USES= fortran guile:2.2 libtool pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared
diff --git a/science/libtensorflow1/Makefile b/science/libtensorflow1/Makefile
index cd0ac8b10120..aad9c82afe93 100644
--- a/science/libtensorflow1/Makefile
+++ b/science/libtensorflow1/Makefile
@@ -119,11 +119,6 @@ XLA_VARS_OFF= TF_ENABLE_XLA=0
BAZEL_OPTS= --output_user_root=${WRKDIR}/bazel_out
-.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} > 1200000 && ${OSVERSION} < 1300000
-EXTRA_PATCHES= ${PATCHDIR}/extra-patch-third_party_repo.bzl
-.endif
-
post-extract:
# THIRD_PARTY_TF_C_LICENSES is generated as a Bazel build target (see
# //tensorflow/tools/lib_package:clicenses) and the empty file written
diff --git a/science/libtensorflow1/files/extra-patch-third_party_repo.bzl b/science/libtensorflow1/files/extra-patch-third_party_repo.bzl
deleted file mode 100644
index eaab437bdc72..000000000000
--- a/science/libtensorflow1/files/extra-patch-third_party_repo.bzl
+++ /dev/null
@@ -1,25 +0,0 @@
---- third_party/repo.bzl.orig
-+++ third_party/repo.bzl
-@@ -62,13 +62,15 @@ def _repos_are_siblings():
- return Label("@foo//bar").workspace_root.startswith("../")
-
- # Apply a patch_file to the repository root directory
--# Runs 'git apply' on Unix, 'patch -p1' on Windows.
-+# Runs 'patch -p1'
- def _apply_patch(ctx, patch_file):
-- if _is_windows(ctx):
-- patch_command = ["patch", "-p1", "-d", ctx.path("."), "-i", ctx.path(patch_file)]
-- else:
-- patch_command = ["git", "apply", "-v", ctx.path(patch_file)]
-- cmd = _wrap_bash_cmd(ctx, patch_command)
-+ # Don't check patch on Windows, because patch is only available under bash.
-+ if not _is_windows(ctx) and not ctx.which("patch"):
-+ fail("patch command is not found, please install it")
-+ cmd = _wrap_bash_cmd(
-+ ctx,
-+ ["patch", "-p1", "-d", ctx.path("."), "-i", ctx.path(patch_file)],
-+ )
- _execute_and_check_ret_code(ctx, cmd)
-
- def _apply_delete(ctx, paths):
-
diff --git a/science/siesta/Makefile b/science/siesta/Makefile
index 3bd84d0c8d90..ed497852d81a 100644
--- a/science/siesta/Makefile
+++ b/science/siesta/Makefile
@@ -12,8 +12,6 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/../COPYING
BROKEN_aarch64= Lack of IEEE754 support in gcc causes "Cannot find an intrinsic module named 'ieee_arithmetic'", see bug#255890
-BROKEN_FreeBSD_12_powerpc= Lack of IEEE754 support in gcc causes "Cannot find an intrinsic module named 'ieee_arithmetic'", see bug#255890
-BROKEN_FreeBSD_12_powerpc64= Lack of IEEE754 support in gcc causes "Cannot find an intrinsic module named 'ieee_arithmetic'", see bug#255890
LIB_DEPENDS= libblas.so:math/blas \
liblapack.so:math/lapack
diff --git a/science/simlib/Makefile b/science/simlib/Makefile
index a6a5f4633a4b..0f4fd449ec11 100644
--- a/science/simlib/Makefile
+++ b/science/simlib/Makefile
@@ -11,7 +11,7 @@ WWW= https://www.fit.vutbr.cz/~peringer/SIMLIB/index.html.en
LICENSE= LGPL20
BROKEN_riscv64= fails to compile: process.cc:53:3: module process.cc is not ported to this processor architecture
-NOT_FOR_ARCHS= aarch64 armv6 armv7 mips mips64 powerpc powerpc64 sparc64
+NOT_FOR_ARCHS= aarch64 armv6 armv7 mips mips64 powerpc powerpc64
NOT_FOR_ARCHS_REASON= contains not working ${ARCH}-dependent assembly code
USES= gmake
diff --git a/science/step/Makefile b/science/step/Makefile
index 4845344aa44a..403ebbe97b68 100644
--- a/science/step/Makefile
+++ b/science/step/Makefile
@@ -23,7 +23,6 @@ USE_QT= concurrent core dbus declarative gui network opengl printsupport svg \
widgets xml \
buildtools:build qmake:build
USE_XORG= x11
-CXXFLAGS_sparc64= -Wno-error=return-type
SHEBANG_FILES= step/data/extractxml
diff --git a/science/zotero/Makefile b/science/zotero/Makefile
index 7400253245c4..1ffc8f5561b5 100644
--- a/science/zotero/Makefile
+++ b/science/zotero/Makefile
@@ -14,7 +14,6 @@ LICENSE= AGPLv3
ONLY_FOR_ARCHS= amd64 i386
ONLY_FOR_ARCHS_REASON= uses FreeBSD 13.x precompiled binaries
-BROKEN_FreeBSD_12= uses FreeBSD 13.x precompiled binaries
LIB_DEPENDS= libasound.so:audio/alsa-lib \
libatk-bridge-2.0.so:accessibility/at-spi2-core \