aboutsummaryrefslogtreecommitdiff
path: root/security/libressl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/libressl/Makefile')
-rw-r--r--security/libressl/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/security/libressl/Makefile b/security/libressl/Makefile
index b83f0ca56b54..436500182ae2 100644
--- a/security/libressl/Makefile
+++ b/security/libressl/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= libressl
-PORTVERSION= 2.5.5
+PORTVERSION= 2.6.3
CATEGORIES= security devel
MASTER_SITES= OPENBSD/LibreSSL
@@ -23,7 +23,6 @@ CONFLICTS_INSTALL= libressl-devel-[0-9]* \
openssl-[0-9]* \
openssl-devel-[0-9]*
-MAN3_EXTRA_PATCHES_OFF= ${FILESDIR}/extra-patch-MAN3
NC_CONFIGURE_ENABLE= nc
GNU_CONFIGURE= yes
@@ -35,6 +34,11 @@ CFLAGS+= -fpic -DPIC -Wl,-rpath,${PREFIX}/lib -Wl,--as-needed
INSTALL_TARGET= install-strip
TEST_TARGET= check
+post-patch-MAN3-off:
+ ${REINPLACE_CMD} -e 's/^install-man: install-man3/install-man:/' \
+ -e '/$$(MAKE) $$(AM_MAKEFLAGS) install-data-hook/d' \
+ ${WRKSRC}/man/Makefile.in
+
post-install:
${RM} -r ${STAGEDIR}/${PREFIX}/etc/ssl/cert.pem