aboutsummaryrefslogtreecommitdiff
path: root/security/libtomcrypt/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/libtomcrypt/Makefile')
-rw-r--r--security/libtomcrypt/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/security/libtomcrypt/Makefile b/security/libtomcrypt/Makefile
index 5158aba23933..681352bf44df 100644
--- a/security/libtomcrypt/Makefile
+++ b/security/libtomcrypt/Makefile
@@ -7,13 +7,24 @@
PORTNAME= libtomcrypt
PORTVERSION= 1.00
+PORTREVISION= 1
CATEGORIES= security
-MASTER_SITES= http://libtomcrypt.org/files/
-DISTNAME= crypt-${PORTVERSION}
+MASTER_SITES= http://libtomcrypt.org/files/:source \
+ http://libtomcrypt.org/files/patch-1.00/:patch
+DISTFILES= crypt-${PORTVERSION}.tar.bz2:source \
+ ltc-1.00-001.tar.bz2:patch
MAINTAINER= onatan@gmail.com
COMMENT= Comprehensive, modular and portable cryptographic toolkit
+EXTRA_PATCHES= ${WRKDIR}/src/pk/pkcs1/pkcs_1_oaep_encode.c.patch \
+ ${WRKDIR}/src/pk/pkcs1/pkcs_1_oaep_decode.c.patch \
+ ${WRKDIR}/src/misc/base64/base64_decode.c.patch \
+ ${WRKDIR}/src/headers/tomcrypt.h.patch \
+ ${WRKDIR}/makefile.shared.patch \
+ ${WRKDIR}/makefile.patch \
+ ${WRKDIR}/changes.patch \
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAKEFILE= makefile
MAKE_ARGS+= PREFIX=${PREFIX}