aboutsummaryrefslogtreecommitdiff
path: root/security/pear-Crypt_DiffieHellman/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/pear-Crypt_DiffieHellman/Makefile')
-rw-r--r--security/pear-Crypt_DiffieHellman/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/security/pear-Crypt_DiffieHellman/Makefile b/security/pear-Crypt_DiffieHellman/Makefile
new file mode 100644
index 000000000000..c33a857038f1
--- /dev/null
+++ b/security/pear-Crypt_DiffieHellman/Makefile
@@ -0,0 +1,27 @@
+# Ports collection makefile for: pear-Crypt_DiffieHellman
+# Date created: 27 Jan 2008
+# Whom: Ditesh Shashikant Gathani <ditesh@gathani.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt_DiffieHellman
+PORTVERSION= 0.2.1
+CATEGORIES= security www pear
+
+MAINTAINER= ditesh@gathani.org
+COMMENT= PEAR class implementing Diffie-Hellman Key Exchange protocol for PHP5
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+
+CATEGORY= Crypt
+FILES= DiffieHellman.php DiffieHellman/Math.php DiffieHellman/Exception.php \
+ DiffieHellman/Math/Exception.php DiffieHellman/Math/BigInteger.php \
+ DiffieHellman/Math/BigInteger/Interface.php DiffieHellman/Math/BigInteger/Gmp.php \
+ DiffieHellman/Math/BigInteger/Exception.php DiffieHellman/Math/BigInteger/Bcmath.php
+TESTS= AllTests.php DiffieHellmanTest.php TestHelper.php TestConfiguration.php.dist
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>