aboutsummaryrefslogtreecommitdiff
path: root/security/pidgin-encryption/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/pidgin-encryption/Makefile')
-rw-r--r--security/pidgin-encryption/Makefile31
1 files changed, 11 insertions, 20 deletions
diff --git a/security/pidgin-encryption/Makefile b/security/pidgin-encryption/Makefile
index 539d6eec1d9a..e2d0d89f16ca 100644
--- a/security/pidgin-encryption/Makefile
+++ b/security/pidgin-encryption/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pidgin
PORTVERSION= 3.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= SF/${PORTNAME}-encrypt/Releases/${PORTVERSION}
PKGNAMESUFFIX= -encryption
@@ -13,37 +13,28 @@ MAINTAINER= perlfu@gmail.com
COMMENT= Encryption Plugin for the Pidgin instant messenger client
BUILD_DEPENDS= ${LOCALBASE}/bin/pidgin:${PORTSDIR}/net-im/pidgin
-LIB_DEPENDS= purple.10:${PORTSDIR}/net-im/libpurple \
- nss3:${PORTSDIR}/security/nss
+RUN_DEPENDS= ${LOCALBASE}/bin/pidgin:${PORTSDIR}/net-im/pidgin
+LIB_DEPENDS= libpurple.so:${PORTSDIR}/net-im/libpurple \
+ libnss3.so:${PORTSDIR}/security/nss
USE_GNOME= gtk20
USES= gettext gmake pkgconfig
GNU_CONFIGURE= yes
-CPPFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-CONFIGURE_ARGS= --with-nspr-includes=${LOCALBASE}/include/nspr \
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS= --disable-static \
+ --with-nspr-includes=${LOCALBASE}/include/nspr \
--with-nspr-libs=${LOCALBASE}/lib \
--with-nss-includes=${LOCALBASE}/include/nss/nss \
--with-nss-libs=${LOCALBASE}/lib/nss
-NO_STAGE= yes
-
OPTIONS_DEFINE= NLS
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-CONFIGURE_ARGS+= --with-libintl-prefix=${LOCALBASE}
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
+OPTIONS_SUB= yes
+NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext
post-extract:
- @${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|glib/.*\.h"|glib.h"|g' ${WRKSRC}/rsa_nss.c
.include <bsd.port.mk>