aboutsummaryrefslogtreecommitdiff
path: root/security/py-mhash/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/py-mhash/Makefile')
-rw-r--r--security/py-mhash/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/security/py-mhash/Makefile b/security/py-mhash/Makefile
index e1c37033f8e8..8f93beb98a33 100644
--- a/security/py-mhash/Makefile
+++ b/security/py-mhash/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mhash
PORTVERSION= 1.4
+PORTREVISION= 1
CATEGORIES= security python
MASTER_SITES= SF/${PORTNAME}/OldFiles
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,6 +12,9 @@ DISTNAME= python-mhash-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Python mhash module
+LICENSE= LGPL21 # or later
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
LIB_DEPENDS= libmhash.so:${PORTSDIR}/security/mhash
USES= python
@@ -19,6 +23,9 @@ USE_PYTHON= distutils autoplist
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/mhash.so
+
test: install
${PYTHON_CMD} ${WRKSRC}/test.py