aboutsummaryrefslogtreecommitdiff
path: root/security/py-pysaml24/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/py-pysaml24/Makefile')
-rw-r--r--security/py-pysaml24/Makefile42
1 files changed, 0 insertions, 42 deletions
diff --git a/security/py-pysaml24/Makefile b/security/py-pysaml24/Makefile
deleted file mode 100644
index c563afcde9db..000000000000
--- a/security/py-pysaml24/Makefile
+++ /dev/null
@@ -1,42 +0,0 @@
-PORTNAME= pysaml2
-PORTVERSION= 4.9.0
-PORTREVISION= 1
-CATEGORIES= security devel python
-MASTER_SITES= PYPI
-PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-PKGNAMESUFFIX= 4
-
-MAINTAINER= sunpoet@FreeBSD.org
-COMMENT= Python implementation of SAML Version 2
-WWW= https://github.com/rohe/pysaml2
-
-LICENSE= APACHE20
-LICENSE_FILE= ${WRKSRC}/LICENSE
-
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}defusedxml>=0:devel/py-defusedxml@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}openssl>=0,1:security/py-openssl@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}Paste>=0:www/py-paste@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}dateutil>=0:devel/py-dateutil@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytz>=0,1:devel/py-pytz@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}repoze.who>=0:devel/py-repoze.who@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}requests>=1.0.0:www/py-requests@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}zope.interface>=0:devel/py-zope.interface@${PY_FLAVOR} \
- xmlsec1:security/xmlsec1
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>=0:devel/py-mock@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}responses>=0:devel/py-responses@${PY_FLAVOR}
-
-USES= cpe python
-USE_PYTHON= autoplist concurrent cryptography distutils
-
-NO_ARCH= yes
-
-CPE_VENDOR= pysaml2_project
-
-PORTSCOUT= limit:^4\.
-
-do-test:
- cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -rs -v
-
-.include <bsd.port.mk>