aboutsummaryrefslogtreecommitdiff
path: root/security/py-txtorcon/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/py-txtorcon/Makefile')
-rw-r--r--security/py-txtorcon/Makefile24
1 files changed, 21 insertions, 3 deletions
diff --git a/security/py-txtorcon/Makefile b/security/py-txtorcon/Makefile
index 02873a49d5fd..c6f08ad91fca 100644
--- a/security/py-txtorcon/Makefile
+++ b/security/py-txtorcon/Makefile
@@ -2,12 +2,12 @@
# $FreeBSD$
PORTNAME= txtorcon
-PORTVERSION= 0.19.3
+DISTVERSION= 0.20.0
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-MAINTAINER= yuri@rawbw.com
+MAINTAINER= yuri@FreeBSD.org
COMMENT= Twisted-based Tor controller client
LICENSE= MIT
@@ -20,8 +20,26 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}twisted>=15.5.0:devel/py-twisted@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}Automat>0:devel/py-Automat@${FLAVOR}
USES= python shebangfix
-USE_PYTHON= distutils autoplist
+USE_PYTHON= distutils autoplist concurrent
NO_ARCH= yes
SHEBANG_FILES= examples/*.py
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+post-patch:
+ @${REINPLACE_CMD} -e " \
+ s|'share/txtorcon'|'${DOCSDIR}'| ; \
+ s|'share/txtorcon/examples'|'${EXAMPLESDIR}'|" \
+ ${WRKSRC}/setup.py
+
+post-patch-DOCS-off:
+ @${REINPLACE_CMD} -E " \
+ s|(.*'${DOCSDIR}'.*)|#\1| ; \
+ s|(.*'docs/.*',$$)|#\1| ; \
+ s|(.*\+ sphinx_docs.*)|#\1|" \
+ ${WRKSRC}/setup.py
+
+post-patch-EXAMPLES-off:
+ @${REINPLACE_CMD} -E "s|(.*'${EXAMPLESDIR}'.*)|#\1|" ${WRKSRC}/setup.py
+
.include <bsd.port.mk>